x11/xterm - The NetBSD Packages Collection

Latest terminal emulator for the X Window System

The xterm program is a terminal emulator for the X Window System.  It provides
DEC VT102 and Tektronix 4014 compatible terminals for programs that can't use
the window system directly.

This version implements ISO/ANSI colors using the "new" color model
(i.e., background color erase). It also implements most of the control
sequences for VT220.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers devel/pkgconf

Runtime dependencies

x11/luit fonts/Xft2 fonts/Xft2 sysutils/desktop-file-utils fonts/Xft2 sysutils/desktop-file-utils

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfxterm-366.tgz
NetBSD 8.0earmv7hfxterm-359.tgz
NetBSD 8.0earmv7hfxterm-367.tgz
NetBSD 8.0i386xterm-359.tgz
NetBSD 8.0i386xterm-366.tgz
NetBSD 8.0i386xterm-367.tgz
NetBSD 8.0powerpcxterm-359.tgz
NetBSD 8.0powerpcxterm-362.tgz
NetBSD 8.0powerpcxterm-366.tgz
NetBSD 8.0powerpcxterm-362.tgz
NetBSD 8.0x86_64xterm-359.tgz
NetBSD 8.0x86_64xterm-366.tgz
NetBSD 9.0aarch64xterm-367.tgz
NetBSD 9.0aarch64xterm-359.tgz
NetBSD 9.0aarch64xterm-366.tgz
NetBSD 9.0alphaxterm-367.tgz
NetBSD 9.0alphaxterm-359.tgz
NetBSD 9.0alphaxterm-362.tgz
NetBSD 9.0alphaxterm-366.tgz
NetBSD 9.0earmxterm-362.tgz
NetBSD 9.0earmv6hfxterm-367.tgz
NetBSD 9.0earmv6hfxterm-359.tgz
NetBSD 9.0earmv6hfxterm-362.tgz
NetBSD 9.0earmv6hfxterm-366.tgz
NetBSD 9.0earmv6hfxterm-366.tgz
NetBSD 9.0earmv7hfxterm-367.tgz
NetBSD 9.0earmv7hfxterm-359.tgz
NetBSD 9.0earmv7hfxterm-366.tgz
NetBSD 9.0earmv7hfxterm-366.tgz
NetBSD 9.0i386xterm-359.tgz
NetBSD 9.0i386xterm-366.tgz
NetBSD 9.0i386xterm-367.tgz
NetBSD 9.0mips64ebxterm-367.tgz
NetBSD 9.0mips64ebxterm-359.tgz
NetBSD 9.0mips64ebxterm-362.tgz
NetBSD 9.0mipselxterm-362.tgz
NetBSD 9.0powerpcxterm-362.tgz
NetBSD 9.0powerpcxterm-359.tgz
NetBSD 9.0sh3elxterm-362.tgz
NetBSD 9.0sparc64xterm-367.tgz
NetBSD 9.0sparc64xterm-344.tgz
NetBSD 9.0sparc64xterm-359.tgz
NetBSD 9.0sparc64xterm-362.tgz
NetBSD 9.0sparc64xterm-366.tgz
NetBSD 9.0sparcxterm-367.tgz
NetBSD 9.0sparcxterm-359.tgz
NetBSD 9.0sparcxterm-362.tgz
NetBSD 9.0x86_64xterm-362.tgz
NetBSD 9.0x86_64xterm-362.tgz
NetBSD 9.0x86_64xterm-363.tgz
NetBSD 9.0x86_64xterm-359.tgz
NetBSD 9.0x86_64xterm-366.tgz
NetBSD 9.0x86_64xterm-367.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

debug
Enable debugging facilities in the package.
freetype
Enable freetype support.
luit
Enable luit support.
pcre
Enable Perl-compatible regular expressions.
xpm
Enable X PixMap image format support.
xterm-toolbar
Enable toolbar support in xterm.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.