audio/dssi - The NetBSD Packages Collection

API for audio processing plugins

DSSI (pronounced "dizzy") is an API for audio processing plugins,
particularly useful for software synthesis plugins with user
interfaces.

DSSI is an open and well-documented specification developed for use
in Linux audio applications, although portable to other platforms.
It may be thought of as LADSPA-for-instruments, or something
comparable to VSTi.

DSSI consists of a C language API for use by plugins and hosts,
based on the LADSPA API, and an OSC (Open Sound Control) API for
use in user interface to host communications.  The DSSI specification
consists of an RFC which describes the background for the proposal
and defines the OSC part of the specification, and a documented
header file which defines the C API.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake textproc/gsed devel/pkgconf

Runtime dependencies

audio/libdssialsacompat audio/libsamplerate audio/libsndfile audio/jack audio/ladspa audio/liblo audio/libsamplerate audio/libsndfile audio/jack audio/ladspa

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfdssi-1.1.1.tgz
NetBSD 8.0earmv7hfdssi-1.1.1.tgz
NetBSD 8.0i386dssi-1.1.1.tgz
NetBSD 8.0i386dssi-1.1.1.tgz
NetBSD 8.0powerpcdssi-1.1.1.tgz
NetBSD 8.0powerpcdssi-1.1.1.tgz
NetBSD 8.0x86_64dssi-1.1.1.tgz
NetBSD 9.0aarch64dssi-1.1.1.tgz
NetBSD 9.0aarch64dssi-1.1.1.tgz
NetBSD 9.0alphadssi-1.1.1.tgz
NetBSD 9.0alphadssi-1.1.1.tgz
NetBSD 9.0earmdssi-1.1.1.tgz
NetBSD 9.0earmdssi-1.1.1.tgz
NetBSD 9.0earmv6hfdssi-1.1.1.tgz
NetBSD 9.0earmv6hfdssi-1.1.1.tgz
NetBSD 9.0earmv6hfdssi-1.1.1.tgz
NetBSD 9.0earmv7hfdssi-1.1.1.tgz
NetBSD 9.0earmv7hfdssi-1.1.1.tgz
NetBSD 9.0earmv7hfdssi-1.1.1.tgz
NetBSD 9.0i386dssi-1.1.1.tgz
NetBSD 9.0i386dssi-1.1.1.tgz
NetBSD 9.0mips64ebdssi-1.1.1.tgz
NetBSD 9.0mips64ebdssi-1.1.1.tgz
NetBSD 9.0powerpcdssi-1.1.1.tgz
NetBSD 9.0sparc64dssi-1.1.1.tgz
NetBSD 9.0sparc64dssi-1.1.1.tgz
NetBSD 9.0x86_64dssi-1.1.1.tgz
NetBSD 9.0x86_64dssi-1.1.1.tgz
NetBSD 9.0x86_64dssi-1.1.1.tgz
NetBSD 9.0x86_64dssi-1.1.1.tgz
NetBSD 9.0x86_64dssi-1.1.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.