audio/gst-plugins0.10-libvisual - The NetBSD Packages Collection

Open source multimedia framework - libvisual plugin

Libvisual is an abstraction library that comes between applications
and audio visualisation plugins.

Often when it comes to audio visualisation plugins or programs that
create visuals, they depend on a player or something else; basically,
there is no general framework that enabled application developers
to easily access cool audio visualisation plugins. Libvisual wants
to change this by providing an interface towards plugins and
applications; through this easy to use interface applications can
easily access plugins and, since the drawing is done by the
application, it also enables the developer to draw the visual
anywhere he wants.

The framework also allows you to morph to different plugins and
mix two at once; all kinds of neat tricks are possible using this
method.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

devel/orc multimedia/gst-plugins0.10-base multimedia/gstreamer0.10 multimedia/gstreamer0.10 devel/glib2 audio/libvisual multimedia/gst-plugins0.10-base multimedia/gstreamer0.10 devel/glib2 audio/libvisual

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0earmv7hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0earmv7hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0i386gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0i386gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0i386gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0powerpcgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0powerpcgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0powerpcgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0x86_64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 8.0x86_64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0aarch64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0aarch64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0aarch64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0alphagst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0alphagst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0alphagst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmv6hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmv6hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmv6hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmv6hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmv7hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmv7hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmv7hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0earmv7hfgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0i386gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0i386gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0i386gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0mips64ebgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0mips64ebgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0powerpcgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0powerpcgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0sparc64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0sparc64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0sparc64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0sparcgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0sparcgst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0x86_64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0x86_64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0x86_64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0x86_64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0x86_64gst-plugins0.10-libvisual-0.10.36nb2.tgz
NetBSD 9.0x86_64gst-plugins0.10-libvisual-0.10.36nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.