audio/gst-plugins0.10-speex - The NetBSD Packages Collection

Open source multimedia framework - speex plugin

The Speex project aims to build an open-source, patent-free voice
codec.  Unlike other codecs like MP3 and Ogg Vorbis, Speex is
specially designed for compressing voice at low bitrates in the
8-32 kbps/channel range.  Possible applications include Voice over
IP (VoIP), internet audio streaming, archiving of speech data (e.g.
voice mail), and audio books.  In some sense, it is meant to be
complementary to the Ogg Vorbis codec.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

multimedia/gst-plugins0.10-good multimedia/gstreamer0.10 multimedia/gstreamer0.10 devel/glib2 multimedia/gst-plugins0.10-base multimedia/gst-plugins0.10-base devel/orc audio/speex multimedia/gst-plugins0.10-good multimedia/gstreamer0.10 devel/glib2 multimedia/gst-plugins0.10-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 8.0earmv7hfgst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 8.0earmv7hfgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 8.0i386gst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 8.0i386gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 8.0i386gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 8.0powerpcgst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 8.0powerpcgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 8.0powerpcgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 8.0x86_64gst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 8.0x86_64gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0aarch64gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0aarch64gst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0aarch64gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0alphagst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0alphagst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0alphagst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0earmgst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0earmv6hfgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0earmv6hfgst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0earmv6hfgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0earmv6hfgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0earmv7hfgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0earmv7hfgst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0earmv7hfgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0earmv7hfgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0i386gst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0i386gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0i386gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0mips64ebgst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0mips64ebgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0powerpcgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0powerpcgst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0sparc64gst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0sparc64gst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0sparc64gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0sparcgst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0sparcgst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0x86_64gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0x86_64gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0x86_64gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0x86_64gst-plugins0.10-speex-0.10.31nb4.tgz
NetBSD 9.0x86_64gst-plugins0.10-speex-0.10.31nb5.tgz
NetBSD 9.0x86_64gst-plugins0.10-speex-0.10.31nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.