audio/libcanberra - The NetBSD Packages Collection

Desktop event sound library

libcanberra is an implementation of the XDG Sound Theme and Name
Specifications, for generating event sounds on free desktops, such as GNOME.
It comes with several backends (ALSA, PulseAudio, OSS, GStreamer, null)
and is designed to be portable.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

x11/gtk2 x11/gtk3 devel/libltdl multimedia/gstreamer1 audio/libvorbis x11/gtk2 x11/gtk3 devel/libltdl multimedia/gstreamer1 audio/libvorbis

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibcanberra-0.30nb4.tgz
NetBSD 8.0earmv7hflibcanberra-0.30nb4.tgz
NetBSD 8.0earmv7hflibcanberra-0.30nb4.tgz
NetBSD 8.0i386libcanberra-0.30nb4.tgz
NetBSD 8.0i386libcanberra-0.30nb4.tgz
NetBSD 8.0i386libcanberra-0.30nb4.tgz
NetBSD 8.0powerpclibcanberra-0.30nb4.tgz
NetBSD 8.0powerpclibcanberra-0.30nb4.tgz
NetBSD 8.0powerpclibcanberra-0.30nb4.tgz
NetBSD 8.0x86_64libcanberra-0.30nb4.tgz
NetBSD 8.0x86_64libcanberra-0.30nb4.tgz
NetBSD 8.0x86_64libcanberra-0.30nb4.tgz
NetBSD 9.0aarch64libcanberra-0.30nb4.tgz
NetBSD 9.0aarch64libcanberra-0.30nb4.tgz
NetBSD 9.0aarch64libcanberra-0.30nb4.tgz
NetBSD 9.0alphalibcanberra-0.30nb4.tgz
NetBSD 9.0alphalibcanberra-0.30nb4.tgz
NetBSD 9.0alphalibcanberra-0.30nb4.tgz
NetBSD 9.0earmlibcanberra-0.30nb4.tgz
NetBSD 9.0earmlibcanberra-0.30nb4.tgz
NetBSD 9.0earmv6hflibcanberra-0.30nb4.tgz
NetBSD 9.0earmv6hflibcanberra-0.30nb4.tgz
NetBSD 9.0earmv6hflibcanberra-0.30nb4.tgz
NetBSD 9.0earmv6hflibcanberra-0.30nb4.tgz
NetBSD 9.0earmv7hflibcanberra-0.30nb4.tgz
NetBSD 9.0earmv7hflibcanberra-0.30nb4.tgz
NetBSD 9.0earmv7hflibcanberra-0.30nb4.tgz
NetBSD 9.0earmv7hflibcanberra-0.30nb4.tgz
NetBSD 9.0i386libcanberra-0.30nb4.tgz
NetBSD 9.0i386libcanberra-0.30nb4.tgz
NetBSD 9.0i386libcanberra-0.30nb4.tgz
NetBSD 9.0m68klibcanberra-0.30nb4.tgz
NetBSD 9.0mips64eblibcanberra-0.30nb4.tgz
NetBSD 9.0mips64eblibcanberra-0.30nb4.tgz
NetBSD 9.0mips64eblibcanberra-0.30nb4.tgz
NetBSD 9.0mipsellibcanberra-0.30nb4.tgz
NetBSD 9.0powerpclibcanberra-0.30nb4.tgz
NetBSD 9.0powerpclibcanberra-0.30nb4.tgz
NetBSD 9.0sh3ellibcanberra-0.30nb4.tgz
NetBSD 9.0sh3ellibcanberra-0.30nb4.tgz
NetBSD 9.0sparc64libcanberra-0.30nb4.tgz
NetBSD 9.0sparc64libcanberra-0.30nb3.tgz
NetBSD 9.0sparc64libcanberra-0.30nb4.tgz
NetBSD 9.0sparc64libcanberra-0.30nb4.tgz
NetBSD 9.0sparclibcanberra-0.30nb4.tgz
NetBSD 9.0sparclibcanberra-0.30nb4.tgz
NetBSD 9.0sparclibcanberra-0.30nb4.tgz
NetBSD 9.0x86_64libcanberra-0.30nb4.tgz
NetBSD 9.0x86_64libcanberra-0.30nb4.tgz
NetBSD 9.0x86_64libcanberra-0.30nb4.tgz
NetBSD 9.0x86_64libcanberra-0.30nb4.tgz
NetBSD 9.0x86_64libcanberra-0.30nb4.tgz
NetBSD 9.0x86_64libcanberra-0.30nb4.tgz
NetBSD 9.0x86_64libcanberra-0.30nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gtk
Enable support for GTK.
gtk3
Enable support for GTK3.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.