audio/libsoxr - The NetBSD Packages Collection

SoX Resample library

The SoX Resampler library 'libsoxr' performs one-dimensional
sample-rate conversion - it may be used, for example, to resample
PCM-encoded audio.

It aims to give fast and high quality results for any constant
(rational or irrational) resampling ratio. Phase-response, preserved
bandwidth, aliasing, and rejection level parameters are all
configurable; alternatively, simple `preset' configurations may be
selected. An experimental, variable-rate resampling mode of operation
is also included.

Build dependencies

pkgtools/cwrappers devel/cmake devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibsoxr-0.1.3.tgz
NetBSD 8.0earmv7hflibsoxr-0.1.3.tgz
NetBSD 8.0earmv7hflibsoxr-0.1.3.tgz
NetBSD 8.0i386libsoxr-0.1.3.tgz
NetBSD 8.0i386libsoxr-0.1.3.tgz
NetBSD 8.0i386libsoxr-0.1.3.tgz
NetBSD 8.0powerpclibsoxr-0.1.3.tgz
NetBSD 8.0powerpclibsoxr-0.1.3.tgz
NetBSD 8.0powerpclibsoxr-0.1.3.tgz
NetBSD 8.0x86_64libsoxr-0.1.3.tgz
NetBSD 8.0x86_64libsoxr-0.1.3.tgz
NetBSD 9.0aarch64libsoxr-0.1.3.tgz
NetBSD 9.0aarch64libsoxr-0.1.3.tgz
NetBSD 9.0aarch64libsoxr-0.1.3.tgz
NetBSD 9.0alphalibsoxr-0.1.3.tgz
NetBSD 9.0alphalibsoxr-0.1.3.tgz
NetBSD 9.0alphalibsoxr-0.1.3.tgz
NetBSD 9.0earmlibsoxr-0.1.3.tgz
NetBSD 9.0earmlibsoxr-0.1.3.tgz
NetBSD 9.0earmlibsoxr-0.1.3.tgz
NetBSD 9.0earmv6hflibsoxr-0.1.3.tgz
NetBSD 9.0earmv6hflibsoxr-0.1.3.tgz
NetBSD 9.0earmv6hflibsoxr-0.1.3.tgz
NetBSD 9.0earmv6hflibsoxr-0.1.3.tgz
NetBSD 9.0earmv7hflibsoxr-0.1.3.tgz
NetBSD 9.0earmv7hflibsoxr-0.1.3.tgz
NetBSD 9.0earmv7hflibsoxr-0.1.3.tgz
NetBSD 9.0earmv7hflibsoxr-0.1.3.tgz
NetBSD 9.0i386libsoxr-0.1.3.tgz
NetBSD 9.0i386libsoxr-0.1.3.tgz
NetBSD 9.0i386libsoxr-0.1.3.tgz
NetBSD 9.0mips64eblibsoxr-0.1.3.tgz
NetBSD 9.0mips64eblibsoxr-0.1.3.tgz
NetBSD 9.0mips64eblibsoxr-0.1.3.tgz
NetBSD 9.0powerpclibsoxr-0.1.3.tgz
NetBSD 9.0powerpclibsoxr-0.1.3.tgz
NetBSD 9.0sh3ellibsoxr-0.1.3.tgz
NetBSD 9.0sh3ellibsoxr-0.1.3.tgz
NetBSD 9.0sparc64libsoxr-0.1.3.tgz
NetBSD 9.0sparc64libsoxr-0.1.3.tgz
NetBSD 9.0sparc64libsoxr-0.1.3.tgz
NetBSD 9.0sparc64libsoxr-0.1.3.tgz
NetBSD 9.0sparclibsoxr-0.1.3.tgz
NetBSD 9.0sparclibsoxr-0.1.3.tgz
NetBSD 9.0sparclibsoxr-0.1.3.tgz
NetBSD 9.0x86_64libsoxr-0.1.3.tgz
NetBSD 9.0x86_64libsoxr-0.1.3.tgz
NetBSD 9.0x86_64libsoxr-0.1.3.tgz
NetBSD 9.0x86_64libsoxr-0.1.3.tgz
NetBSD 9.0x86_64libsoxr-0.1.3.tgz
NetBSD 9.0x86_64libsoxr-0.1.3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.