audio/qjackctl - The NetBSD Packages Collection

JACK Audio Connection Kit Qt GUI

QjackCtl is a simple Qt application to control the JACK sound server
daemon, specific for the Linux Audio Desktop infrastructure.

Written in C++ around the Qt4 toolkit for X11, most exclusively using
Qt Designer.

Provides a simple GUI dialog for setting several JACK daemon parameters,
which are properly saved between sessions, and a way control of the status
of the audio server daemon. With time, this primordial interface has become
richer by including a enhanced patchbay and connection control features.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/gmake

Runtime dependencies

audio/jack graphics/hicolor-icon-theme sysutils/desktop-file-utils x11/qt5-qtbase x11/qt5-qttools x11/qt5-qtx11extras audio/jack graphics/hicolor-icon-theme sysutils/desktop-file-utils x11/qt5-qtbase x11/qt5-qttools x11/qt5-qtx11extras

Binary packages

OSArchitectureVersion
NetBSD 9.0aarch64qjackctl-0.4.2nb31.tgz
NetBSD 9.0aarch64qjackctl-0.4.2nb28.tgz
NetBSD 9.0aarch64qjackctl-0.4.2nb29.tgz
NetBSD 9.0earmv7hfqjackctl-0.4.2nb28.tgz
NetBSD 9.0i386qjackctl-0.4.2nb28.tgz
NetBSD 9.0i386qjackctl-0.4.2nb29.tgz
NetBSD 9.0i386qjackctl-0.4.2nb31.tgz
NetBSD 9.0powerpcqjackctl-0.4.2nb29.tgz
NetBSD 9.0sparc64qjackctl-0.4.2nb28.tgz
NetBSD 9.0x86_64qjackctl-0.4.2nb29.tgz
NetBSD 9.0x86_64qjackctl-0.4.2nb30.tgz
NetBSD 9.0x86_64qjackctl-0.4.2nb30.tgz
NetBSD 9.0x86_64qjackctl-0.4.2nb28.tgz
NetBSD 9.0x86_64qjackctl-0.4.2nb29.tgz
NetBSD 9.0x86_64qjackctl-0.4.2nb31.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.