audio/speexdsp - The NetBSD Packages Collection

Open-source, patent-free voice codec DSP library

The Speex project aims to build an open-source, patent-free voice
codec.  Unlike other codecs like MP3 and Ogg Vorbis, Speex is
specially designed for compressing voice at low bitrates in the
8-32 kbps/channel range.  Possible applications include Voice over
IP (VoIP), internet audio streaming, archiving of speech data (e.g.
voice mail), and audio books.  In some sense, it is meant to be
complementary to the Ogg Vorbis codec.

This package contains a DSP library to use with speex.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

audio/speex audio/speex

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfspeexdsp-1.2.0.tgz
NetBSD 8.0earmv7hfspeexdsp-1.2.0.tgz
NetBSD 8.0earmv7hfspeexdsp-1.2.0.tgz
NetBSD 8.0i386speexdsp-1.2.0.tgz
NetBSD 8.0i386speexdsp-1.2.0.tgz
NetBSD 8.0i386speexdsp-1.2.0.tgz
NetBSD 8.0powerpcspeexdsp-1.2.0.tgz
NetBSD 8.0powerpcspeexdsp-1.2.0.tgz
NetBSD 8.0powerpcspeexdsp-1.2.0.tgz
NetBSD 8.0x86_64speexdsp-1.2.0.tgz
NetBSD 8.0x86_64speexdsp-1.2.0.tgz
NetBSD 8.0x86_64speexdsp-1.2.0.tgz
NetBSD 9.0aarch64speexdsp-1.2.0.tgz
NetBSD 9.0aarch64speexdsp-1.2.0.tgz
NetBSD 9.0aarch64speexdsp-1.2.0.tgz
NetBSD 9.0alphaspeexdsp-1.2.0.tgz
NetBSD 9.0alphaspeexdsp-1.2.0.tgz
NetBSD 9.0alphaspeexdsp-1.2.0.tgz
NetBSD 9.0earmspeexdsp-1.2.0.tgz
NetBSD 9.0earmspeexdsp-1.2.0.tgz
NetBSD 9.0earmspeexdsp-1.2.0.tgz
NetBSD 9.0earmv6hfspeexdsp-1.2.0.tgz
NetBSD 9.0earmv6hfspeexdsp-1.2.0.tgz
NetBSD 9.0earmv6hfspeexdsp-1.2.0.tgz
NetBSD 9.0earmv6hfspeexdsp-1.2.0.tgz
NetBSD 9.0earmv7hfspeexdsp-1.2.0.tgz
NetBSD 9.0earmv7hfspeexdsp-1.2.0.tgz
NetBSD 9.0earmv7hfspeexdsp-1.2.0.tgz
NetBSD 9.0earmv7hfspeexdsp-1.2.0.tgz
NetBSD 9.0earmv7hfspeexdsp-1.2.0.tgz
NetBSD 9.0i386speexdsp-1.2.0.tgz
NetBSD 9.0i386speexdsp-1.2.0.tgz
NetBSD 9.0i386speexdsp-1.2.0.tgz
NetBSD 9.0m68kspeexdsp-1.2.0.tgz
NetBSD 9.0m68kspeexdsp-1.2.0.tgz
NetBSD 9.0m68kspeexdsp-1.2.0.tgz
NetBSD 9.0mips64ebspeexdsp-1.2.0.tgz
NetBSD 9.0mips64ebspeexdsp-1.2.0.tgz
NetBSD 9.0mips64ebspeexdsp-1.2.0.tgz
NetBSD 9.0mipselspeexdsp-1.2.0.tgz
NetBSD 9.0mipselspeexdsp-1.2.0.tgz
NetBSD 9.0powerpcspeexdsp-1.2.0.tgz
NetBSD 9.0powerpcspeexdsp-1.2.0.tgz
NetBSD 9.0powerpcspeexdsp-1.2.0.tgz
NetBSD 9.0sh3elspeexdsp-1.2.0.tgz
NetBSD 9.0sh3elspeexdsp-1.2.0.tgz
NetBSD 9.0sh3elspeexdsp-1.2.0.tgz
NetBSD 9.0sparc64speexdsp-1.2.0.tgz
NetBSD 9.0sparc64speexdsp-1.2.0.tgz
NetBSD 9.0sparc64speexdsp-1.2.0.tgz
NetBSD 9.0sparc64speexdsp-1.2.0.tgz
NetBSD 9.0sparcspeexdsp-1.2.0.tgz
NetBSD 9.0sparcspeexdsp-1.2.0.tgz
NetBSD 9.0sparcspeexdsp-1.2.0.tgz
NetBSD 9.0vaxspeexdsp-1.2.0.tgz
NetBSD 9.0vaxspeexdsp-1.2.0.tgz
NetBSD 9.0x86_64speexdsp-1.2.0.tgz
NetBSD 9.0x86_64speexdsp-1.2.0.tgz
NetBSD 9.0x86_64speexdsp-1.2.0.tgz
NetBSD 9.0x86_64speexdsp-1.2.0.tgz
NetBSD 9.0x86_64speexdsp-1.2.0.tgz
NetBSD 9.0x86_64speexdsp-1.2.0.tgz
NetBSD 9.0x86_64speexdsp-1.2.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.