audio/suil - The NetBSD Packages Collection

Lightweight C library for loading and wrapping LV2 plugin UIs

Suil is a lightweight C library for loading and wrapping LV2 plugin
UIs.

Suil makes it possible to load a UI of any toolkit in a host using
any other toolkit (assuming the toolkits are both supported by
Suil). Hosts do not need to build against or link to foreign toolkit
libraries to use UIs written with that toolkit; all the necessary
magic is performed by dynamically loaded modules. The API is designed
such that hosts do not need to explicitly support specific toolkits
at all - if Suil supports a particular toolkit, then UIs in that
toolkit will work in all hosts that use Suil automatically.

Build dependencies

pkgtools/x11-links x11/xcb-proto x11/xorgproto pkgtools/cwrappers lang/python38 devel/glib2-tools devel/pkgconf

Runtime dependencies

audio/lv2 x11/gtk2 x11/gtk3 audio/lv2 x11/gtk2 x11/gtk3

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsuil-0.10.8.tgz
NetBSD 8.0earmv7hfsuil-0.10.10.tgz
NetBSD 8.0i386suil-0.10.6nb4.tgz
NetBSD 8.0i386suil-0.10.8.tgz
NetBSD 8.0i386suil-0.10.10.tgz
NetBSD 8.0powerpcsuil-0.10.6nb4.tgz
NetBSD 8.0powerpcsuil-0.10.8.tgz
NetBSD 8.0powerpcsuil-0.10.8.tgz
NetBSD 8.0x86_64suil-0.10.6nb4.tgz
NetBSD 8.0x86_64suil-0.10.8.tgz
NetBSD 9.0aarch64suil-0.10.10.tgz
NetBSD 9.0aarch64suil-0.10.6nb4.tgz
NetBSD 9.0aarch64suil-0.10.8.tgz
NetBSD 9.0alphasuil-0.10.10.tgz
NetBSD 9.0alphasuil-0.10.6nb4.tgz
NetBSD 9.0alphasuil-0.10.8.tgz
NetBSD 9.0earmv6hfsuil-0.10.10.tgz
NetBSD 9.0earmv6hfsuil-0.10.6nb4.tgz
NetBSD 9.0earmv6hfsuil-0.10.8.tgz
NetBSD 9.0earmv6hfsuil-0.10.8.tgz
NetBSD 9.0earmv7hfsuil-0.10.10.tgz
NetBSD 9.0earmv7hfsuil-0.10.6nb4.tgz
NetBSD 9.0earmv7hfsuil-0.10.8.tgz
NetBSD 9.0earmv7hfsuil-0.10.8.tgz
NetBSD 9.0i386suil-0.10.6nb4.tgz
NetBSD 9.0i386suil-0.10.8.tgz
NetBSD 9.0i386suil-0.10.10.tgz
NetBSD 9.0mips64ebsuil-0.10.6nb4.tgz
NetBSD 9.0mips64ebsuil-0.10.8.tgz
NetBSD 9.0powerpcsuil-0.10.8.tgz
NetBSD 9.0powerpcsuil-0.10.6nb4.tgz
NetBSD 9.0sh3elsuil-0.10.8.tgz
NetBSD 9.0sparc64suil-0.10.6nb2.tgz
NetBSD 9.0sparc64suil-0.10.6nb4.tgz
NetBSD 9.0sparc64suil-0.10.8.tgz
NetBSD 9.0sparcsuil-0.10.6nb4.tgz
NetBSD 9.0sparcsuil-0.10.8.tgz
NetBSD 9.0x86_64suil-0.10.6nb4.tgz
NetBSD 9.0x86_64suil-0.10.8.tgz
NetBSD 9.0x86_64suil-0.10.10.tgz
NetBSD 9.0x86_64suil-0.10.6nb4.tgz
NetBSD 9.0x86_64suil-0.10.8.tgz
NetBSD 9.0x86_64suil-0.10.10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.