audio/vamp-plugin-sdk - The NetBSD Packages Collection

The Vamp audio analysis plugin system

Vamp is an audio processing plugin system for plugins that extract descriptive
information from audio typically referred to as audio analysis plugins or
audio feature extraction plugins.

Just like an audio effects plugin (such as a VST), a Vamp plugin is a binary
module that can be loaded up by a host application and fed audio data. However,
unlike an effects plugin, a Vamp plugin generates not more audio, but some sort
of symbolic information. Typical things that a Vamp plugin might calculate
include the locations of moments such as note onset times, visualisable
representations of the audio such as spectrograms, or curve data such as power
or fundamental frequency.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

audio/libsndfile audio/libsndfile

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfvamp-plugin-sdk-2.10.0.tgz
NetBSD 8.0earmv7hfvamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 8.0earmv7hfvamp-plugin-sdk-2.10.0.tgz
NetBSD 8.0i386vamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 8.0i386vamp-plugin-sdk-2.10.0.tgz
NetBSD 8.0i386vamp-plugin-sdk-2.10.0.tgz
NetBSD 8.0powerpcvamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 8.0powerpcvamp-plugin-sdk-2.10.0.tgz
NetBSD 8.0powerpcvamp-plugin-sdk-2.10.0.tgz
NetBSD 8.0x86_64vamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 8.0x86_64vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0aarch64vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0aarch64vamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0aarch64vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0alphavamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0alphavamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0alphavamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0earmvamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0earmvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0earmv6hfvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0earmv6hfvamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0earmv6hfvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0earmv6hfvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0earmv7hfvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0earmv7hfvamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0earmv7hfvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0earmv7hfvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0i386vamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0i386vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0i386vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0mips64ebvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0mips64ebvamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0mips64ebvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0mipselvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0powerpcvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0powerpcvamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0sh3elvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0sparc64vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0sparc64vamp-plugin-sdk-2.9.0.tgz
NetBSD 9.0sparc64vamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0sparc64vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0sparcvamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0sparcvamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0x86_64vamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0x86_64vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0x86_64vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0x86_64vamp-plugin-sdk-2.9.0nb1.tgz
NetBSD 9.0x86_64vamp-plugin-sdk-2.10.0.tgz
NetBSD 9.0x86_64vamp-plugin-sdk-2.10.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.