benchmarks/flops - The NetBSD Packages Collection

Floating point benchmark to give your MFLOPS rating

   Flops.c is a 'c' program which attempts to estimate your systems
   floating-point 'MFLOPS' rating for the FADD, FSUB, FMUL, and FDIV
   operations based on specific 'instruction mixes' (discussed below).
   The program provides an estimate of PEAK MFLOPS performance by making
   maximal use of register variables with minimal interaction with main
   memory. The execution loops are all small so that they will fit in
   any cache. Flops.c can be used along with Linpack and the Livermore
   kernels (which exercise memory much more extensively) to gain further
   insight into the limits of system performance. The flops.c execution
   modules include various percent weightings of FDIV's (from 0% to 25%
   FDIV's) so that the range of performance can be obtained when using
   FDIV's. FDIV's, being computationally more intensive than FADD's or
   FMUL's, can impact performance considerably on some systems.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfflops-2.0.tgz
NetBSD 8.0earmv7hfflops-2.0.tgz
NetBSD 8.0earmv7hfflops-2.0.tgz
NetBSD 8.0i386flops-2.0.tgz
NetBSD 8.0i386flops-2.0.tgz
NetBSD 8.0i386flops-2.0.tgz
NetBSD 8.0powerpcflops-2.0.tgz
NetBSD 8.0powerpcflops-2.0.tgz
NetBSD 8.0powerpcflops-2.0.tgz
NetBSD 8.0x86_64flops-2.0.tgz
NetBSD 8.0x86_64flops-2.0.tgz
NetBSD 8.0x86_64flops-2.0.tgz
NetBSD 9.0aarch64flops-2.0.tgz
NetBSD 9.0aarch64flops-2.0.tgz
NetBSD 9.0aarch64flops-2.0.tgz
NetBSD 9.0alphaflops-2.0.tgz
NetBSD 9.0alphaflops-2.0.tgz
NetBSD 9.0alphaflops-2.0.tgz
NetBSD 9.0earmflops-2.0.tgz
NetBSD 9.0earmv6hfflops-2.0.tgz
NetBSD 9.0earmv6hfflops-2.0.tgz
NetBSD 9.0earmv6hfflops-2.0.tgz
NetBSD 9.0earmv6hfflops-2.0.tgz
NetBSD 9.0earmv7hfflops-2.0.tgz
NetBSD 9.0earmv7hfflops-2.0.tgz
NetBSD 9.0earmv7hfflops-2.0.tgz
NetBSD 9.0earmv7hfflops-2.0.tgz
NetBSD 9.0i386flops-2.0.tgz
NetBSD 9.0i386flops-2.0.tgz
NetBSD 9.0i386flops-2.0.tgz
NetBSD 9.0m68kflops-2.0.tgz
NetBSD 9.0m68kflops-2.0.tgz
NetBSD 9.0m68kflops-2.0.tgz
NetBSD 9.0mips64ebflops-2.0.tgz
NetBSD 9.0mips64ebflops-2.0.tgz
NetBSD 9.0mips64ebflops-2.0.tgz
NetBSD 9.0powerpcflops-2.0.tgz
NetBSD 9.0powerpcflops-2.0.tgz
NetBSD 9.0sparc64flops-2.0.tgz
NetBSD 9.0sparc64flops-2.0.tgz
NetBSD 9.0sparc64flops-2.0.tgz
NetBSD 9.0sparc64flops-2.0.tgz
NetBSD 9.0sparcflops-2.0.tgz
NetBSD 9.0sparcflops-2.0.tgz
NetBSD 9.0sparcflops-2.0.tgz
NetBSD 9.0x86_64flops-2.0.tgz
NetBSD 9.0x86_64flops-2.0.tgz
NetBSD 9.0x86_64flops-2.0.tgz
NetBSD 9.0x86_64flops-2.0.tgz
NetBSD 9.0x86_64flops-2.0.tgz
NetBSD 9.0x86_64flops-2.0.tgz
NetBSD 9.0x86_64flops-2.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.