cad/felt - The NetBSD Packages Collection

Free system for introductory level finite element analysis

FElt is a free system for introductory level finite element
analysis. It is primarily intended as a teaching tool for introductory
type courses in finite elements - probably in the
mechanical/structural/civil fields. In a command line environment,
FElt uses an intuitive, straightforward input syntax to describe
problems. It also includes a graphical user interface for workstations
that allows the user to set-up, solve and post-process the problem in
a single CAD-like environment.

From the end-user point of view, FElt consists of six programs: felt,
burlap, velvet, corduroy, patchwork, and yardstick. felt is the basic
command-line application; burlap is an interactive Matlab-like
environment for scripting your own elements and analyses; velvet is
the primary GUI interface into the bulk of the functionality in FElt;
corduroy is command-line program for automatic element generation;
patchwork is a command-line application for file format conversion to
and from the FElt syntax; and yardstick is a simple program for
problem scaling and unit conversion.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers

Runtime dependencies

devel/readline x11/libXaw3d devel/readline

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffelt-3.05nb5.tgz
NetBSD 8.0earmv7hffelt-3.05nb5.tgz
NetBSD 8.0earmv7hffelt-3.05nb5.tgz
NetBSD 8.0i386felt-3.05nb5.tgz
NetBSD 8.0i386felt-3.05nb5.tgz
NetBSD 8.0i386felt-3.05nb5.tgz
NetBSD 8.0powerpcfelt-3.05nb5.tgz
NetBSD 8.0powerpcfelt-3.05nb5.tgz
NetBSD 8.0powerpcfelt-3.05nb5.tgz
NetBSD 8.0x86_64felt-3.05nb5.tgz
NetBSD 8.0x86_64felt-3.05nb5.tgz
NetBSD 8.0x86_64felt-3.05nb5.tgz
NetBSD 9.0aarch64felt-3.05nb5.tgz
NetBSD 9.0aarch64felt-3.05nb5.tgz
NetBSD 9.0aarch64felt-3.05nb5.tgz
NetBSD 9.0alphafelt-3.05nb5.tgz
NetBSD 9.0alphafelt-3.05nb5.tgz
NetBSD 9.0alphafelt-3.05nb5.tgz
NetBSD 9.0earmv6hffelt-3.05nb5.tgz
NetBSD 9.0earmv6hffelt-3.05nb5.tgz
NetBSD 9.0earmv6hffelt-3.05nb5.tgz
NetBSD 9.0earmv6hffelt-3.05nb5.tgz
NetBSD 9.0earmv7hffelt-3.05nb5.tgz
NetBSD 9.0earmv7hffelt-3.05nb5.tgz
NetBSD 9.0earmv7hffelt-3.05nb5.tgz
NetBSD 9.0earmv7hffelt-3.05nb5.tgz
NetBSD 9.0earmv7hffelt-3.05nb5.tgz
NetBSD 9.0i386felt-3.05nb5.tgz
NetBSD 9.0i386felt-3.05nb5.tgz
NetBSD 9.0i386felt-3.05nb5.tgz
NetBSD 9.0mips64ebfelt-3.05nb5.tgz
NetBSD 9.0mips64ebfelt-3.05nb5.tgz
NetBSD 9.0mips64ebfelt-3.05nb5.tgz
NetBSD 9.0powerpcfelt-3.05nb5.tgz
NetBSD 9.0powerpcfelt-3.05nb5.tgz
NetBSD 9.0powerpcfelt-3.05nb5.tgz
NetBSD 9.0sparc64felt-3.05nb5.tgz
NetBSD 9.0sparc64felt-3.05nb5.tgz
NetBSD 9.0sparc64felt-3.05nb5.tgz
NetBSD 9.0sparcfelt-3.05nb5.tgz
NetBSD 9.0sparcfelt-3.05nb5.tgz
NetBSD 9.0sparcfelt-3.05nb5.tgz
NetBSD 9.0x86_64felt-3.05nb5.tgz
NetBSD 9.0x86_64felt-3.05nb5.tgz
NetBSD 9.0x86_64felt-3.05nb5.tgz
NetBSD 9.0x86_64felt-3.05nb5.tgz
NetBSD 9.0x86_64felt-3.05nb5.tgz
NetBSD 9.0x86_64felt-3.05nb5.tgz
NetBSD 9.0x86_64felt-3.05nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.