Daemon Power

The NetBSD Packages Collection: chat/libfolks

Brief description of the package:
Library to manage contacts

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://wiki.gnome.org/Projects/Folks.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "chat/libfolks" directory. The current source version of the package is "libfolks-0.14.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for chat/libfolks :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: telepathy-glib>=0.7.18 glib2>=2.36 pcre>=3.4nb1 cwrappers>=20150314 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 meson-[0-9]* ninja-build>=1.7 python37>=3.7 libuuid>=2.18 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.8 glib2>=2.4.0 gobject-introspection>=1.30.0 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 glib2>=2.64.0nb1 gobject-introspection>=0.6.14nb1 vala>=0.48 glib2>=2.48.0 libltdl>=2.4.2 graphviz>=2.26.3 gd>=2.0.15nb1 perl>=5.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.2.1nb3 png>=1.2.4 tiff>=4.0.3nb5 giflib>=5.2.1nb4 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 gtk2+>=2.4.0 py27-expat-[0-9]* shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb2 atk>=1.30.0 glib2>=2.38.0 gobject-introspection>=1.62.0nb1 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 shared-mime-info>=1.0nb1 xcursor>=1.0 Xfixes>=2.0.0 x11-links>=1.31 osabi-NetBSD-9.0_STABLE fixesproto>=3.0.0<5 xorgproto>=2016.1 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 Xft2>=2.1.2nb2 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 Xft2>=2.1.7nb3 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.59 harfbuzz>=2.0 icu>=3.4 graphite2>=1.2 icu>=67.1 gtk-doc>=1.18 docbook-xml>=4.4nb1 docbook-xsl>=1.68.1 docbook-xml>=4.2 py37-anytree-[0-9]* py37-six>=1.9.0 py37-lxml-[0-9]* libxml2>=2.9.2 libxslt>=1.1.27 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.8 libxslt>=1.1.34nb2 py37-pygments-[0-9]* pkgconf-[0-9]* itstool-[0-9]* py37-libxml2-[0-9]* libxml2>=2.9.10 py37-expat>=0 gnome-doc-utils>=0.8.0 py27-libxml2>=2.6.16 py27-libxslt>=1.1.12 py27-libxml2>=2.6.8 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 py27-libxml2>=2.6.27 libxslt>=1.1.34 python27>=2.7.1nb2 docbook-xml>=4.5 getopt-[0-9]* bash-[0-9]* libxml2>=2.6.12 gtk-doc>=1.32nb2 harfbuzz>=2.1.1 cairo>=1.12.10 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.14 xcb-proto>=1.4 lzo>=2.01 pixman>=0.30.0 pixman>=0.25.2 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.16.0 glib2>=2.14.0 Xft2>=2.1.7nb7 harfbuzz>=2.6.4nb2 cairo-gobject>=1.16.0nb4 pango>=1.6.0 cairo>=1.6.0 atk>=2.33.3nb1 gdk-pixbuf2>=2.40.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.44.7nb2 gobject-introspection>=0.9.3 lua53>=5.3.0<5.4 tk>=8.5.7 libXScrnSaver>=1.1.2 tcl>=8.5.7 sqlite3>=3.30.1.2 sqlite3>=3.0.8 sqlite3>=3.32.1nb1 tcl>=8.6.1nb1 perl>=5.30.0 perl<5.32.0 gts>=0.7.6 netpbm>=10.11.6 netpbm>=10.35.80nb6 gd>=2.2.5nb2 gtk2+>=2.24.32nb13 tk>=8.6.8nb1 libltdl>=2.2.6 gts>=0.7.6nb1 swig>=1.3.24<2.0 swig>=1.3.31<2.0 graphviz>=2.40.1nb22 libxslt-[0-9]* dbus-glib>=0.90 glib2>=2.40 dbus>=1.8 xmlto-[0-9]* docbook-xsl>=1.67.0nb1 dbus>=0.91 dbus-glib>=0.61 dbus>=0.95 vala>=0.48.0 dbus-glib>=0.110nb1 libgee>=0.8.2 vala>=0.25.1 telepathy-glib>=0.24.1nb13 libgee>=0.20.1nb3 .

This package requires the following package(s) to run: telepathy-glib>=0.7.18 glib2>=2.36 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 glib2>=2.4.0 gobject-introspection>=1.30.0 py37-cElementTree-[0-9]* python37>=3.7 libuuid>=2.18 python37>=3.7.0 python37>=3.7.8 py37-expat-[0-9]* glib2>=2.58.0 libffi>=3.0.0 glib2>=2.64.0nb1 gobject-introspection>=0.6.14nb1 vala>=0.48 glib2>=2.48.0 libltdl>=2.4.2 graphviz>=2.26.3 gd>=2.0.15nb1 perl>=5.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.2.1nb3 png>=1.2.4 tiff>=4.0.3nb5 giflib>=5.2.1nb4 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 gtk2+>=2.4.0 py27-expat-[0-9]* shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb2 atk>=1.30.0 glib2>=2.38.0 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 shared-mime-info>=1.0nb1 xcursor>=1.0 Xfixes>=2.0.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 Xft2>=2.1.2nb2 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 Xft2>=2.1.7nb3 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.59 harfbuzz>=2.0 icu>=3.4 graphite2>=1.2 icu>=67.1 harfbuzz>=2.1.1 cairo>=1.12.10 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 pixman>=0.30.0 pixman>=0.25.2 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.16.0 glib2>=2.14.0 Xft2>=2.1.7nb7 harfbuzz>=2.6.4nb2 cairo-gobject>=1.16.0nb4 pango>=1.6.0 cairo>=1.6.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 atk>=2.33.3nb1 gdk-pixbuf2>=2.40.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.44.7nb2 python27>=2.7.1nb2 lua53>=5.3.0<5.4 tk>=8.5.7 libXScrnSaver>=1.1.2 tcl>=8.5.7 sqlite3>=3.30.1.2 sqlite3>=3.0.8 sqlite3>=3.32.1nb1 tcl>=8.6.1nb1 perl>=5.30.0 perl<5.32.0 gts>=0.7.6 netpbm>=10.11.6 netpbm>=10.35.80nb6 gd>=2.2.5nb2 gtk2+>=2.24.32nb13 tk>=8.6.8nb1 libltdl>=2.2.6 gts>=0.7.6nb1 graphviz>=2.40.1nb22 dbus-glib>=0.90 glib2>=2.40 dbus>=1.8 dbus>=0.91 dbus-glib>=0.61 dbus>=0.95 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 gobject-introspection>=1.62.0nb1 vala>=0.48.0 dbus-glib>=0.110nb1 libxslt>=1.1.34nb2 libgee>=0.8.2 readline>=2.2 telepathy-glib>=0.24.1nb13 libgee>=0.20.1nb3 readline>=6.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:libfolks-0.14.0.tgz(NetBSD 9.0)
aarch64:libfolks-0.4.2nb5.tgz(NetBSD 9.0)
aarch64:libfolks-0.4.2nb6.tgz(NetBSD 9.0)
alpha:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
alpha:libfolks-0.4.2nb5.tgz(NetBSD 9.0)
earm:libfolks-0.4.2nb5.tgz(NetBSD 7.0)
earmv6hf:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
earmv6hf:libfolks-0.4.2nb5.tgz(NetBSD 9.0)
earmv7hf:libfolks-0.14.0.tgz(NetBSD 8.0)
earmv7hf:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
earmv7hf:libfolks-0.4.2nb6.tgz(NetBSD 8.0)
earmv7hf:libfolks-0.4.2nb5.tgz(NetBSD 9.0)
earmv7hf:libfolks-0.4.2nb6.tgz(NetBSD 9.0)
i386:libfolks-0.4.2nb6.tgz(NetBSD 9.0)
i386:libfolks-0.4.2nb5.tgz(NetBSD 7.0)
i386:libfolks-0.4.2nb5.tgz(NetBSD 7.0)
i386:libfolks-0.4.2nb5.tgz(NetBSD 7.1)
i386:libfolks-0.4.2nb5.tgz(NetBSD 7.1)
i386:libfolks-0.4.2nb6.tgz(NetBSD 7.1)
i386:libfolks-0.14.0.tgz(NetBSD 8.0)
i386:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
i386:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
i386:libfolks-0.4.2nb6.tgz(NetBSD 8.0)
i386:libfolks-0.14.0.tgz(NetBSD 9.0)
i386:libfolks-0.4.2nb5.tgz(NetBSD 9.0)
i386:libfolks-0.4.2nb6.tgz(NetBSD 9.0)
mips64eb:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
powerpc:libfolks-0.4.2nb5.tgz(NetBSD 7.1)
sparc64:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
sparc64:libfolks-0.4.2nb5.tgz(NetBSD 9.0)
sparc:libfolks-0.4.2nb5.tgz(NetBSD 7.0)
x86_64:libfolks-0.14.0.tgz(NetBSD 9.0)
x86_64:libfolks-0.4.2nb6.tgz(NetBSD 9.0)
x86_64:libfolks-0.4.2nb5.tgz(NetBSD 7.0)
x86_64:libfolks-0.4.2nb5.tgz(NetBSD 7.0)
x86_64:libfolks-0.4.2nb5.tgz(NetBSD 7.1)
x86_64:libfolks-0.4.2nb5.tgz(NetBSD 7.1)
x86_64:libfolks-0.4.2nb6.tgz(NetBSD 7.1)
x86_64:libfolks-0.4.2nb6.tgz(NetBSD 8.0)
x86_64:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
x86_64:libfolks-0.4.2nb5.tgz(NetBSD 8.0)
x86_64:libfolks-0.14.0.tgz(NetBSD 8.0)
x86_64:libfolks-0.14.0.tgz(NetBSD 9.0)
x86_64:libfolks-0.4.2nb5.tgz(NetBSD 9.0)
x86_64:libfolks-0.4.2nb6.tgz(NetBSD 9.0)
x86_64:libfolks-0.14.0.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]