databases/gramps5 - The NetBSD Packages Collection

Genealogical Research and Analysis Management Programming System V5

Gramps (Genealogical Research and Analysis Management Programming System)
is a personal genealogy program. It provides a graphical interface for
recording genealogical research.

Gramps can import GEDCOM format and export to GEDCOM and Web Family Tree.
It can generate book reports, ancestor charts, relationship graphs, timelines,
Ahnentafel reports, websites, and various other comprehensive reports
in various documentation formats.

Gramps can also include extra media types (like JPEG images and audio
files), record sources of information, and keep track of locations
(place names).

This version is the currently maintained version using Python 3.x and GTK3.

Build dependencies

devel/py-setuptools pkgtools/mktools textproc/intltool lang/perl5 devel/pkgconf pkgtools/cwrappers

Runtime dependencies

graphics/librsvg devel/py-gobject3 databases/py-bsddb3 graphics/gnome-icon-theme databases/shared-mime-info graphics/gnome-icon-theme databases/shared-mime-info

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64gramps-5.1.6nb2.tgz
NetBSD 10.0aarch64gramps-5.1.6nb2.tgz
NetBSD 10.0aarch64gramps-5.1.6nb2.tgz
NetBSD 10.0earmv7hfgramps-5.1.6nb2.tgz
NetBSD 10.0earmv7hfgramps-5.1.6nb2.tgz
NetBSD 10.0i386gramps-5.1.6nb2.tgz
NetBSD 10.0i386gramps-5.1.6nb2.tgz
NetBSD 10.0i386gramps-5.1.6nb2.tgz
NetBSD 10.0powerpcgramps-5.1.6nb1.tgz
NetBSD 10.0powerpcgramps-5.1.6nb2.tgz
NetBSD 10.0x86_64gramps-5.1.6nb2.tgz
NetBSD 10.0x86_64gramps-5.1.6nb2.tgz
NetBSD 10.0x86_64gramps-5.1.6nb2.tgz
NetBSD 9.0aarch64gramps-5.1.6nb2.tgz
NetBSD 9.0earmv7hfgramps-5.1.6nb2.tgz
NetBSD 9.0earmv7hfgramps-5.1.6nb2.tgz
NetBSD 9.0i386gramps-5.1.6nb2.tgz
NetBSD 9.0i386gramps-5.1.6nb2.tgz
NetBSD 9.0i386gramps-5.1.6nb2.tgz
NetBSD 9.0powerpcgramps-5.1.6nb2.tgz
NetBSD 9.0powerpcgramps-5.1.6nb1.tgz
NetBSD 9.0powerpcgramps-5.1.6nb2.tgz
NetBSD 9.0x86_64gramps-5.1.6nb2.tgz
NetBSD 9.0x86_64gramps-5.1.6nb2.tgz
NetBSD 9.0x86_64gramps-5.1.6nb2.tgz
NetBSD 9.3x86_64gramps-5.1.6nb2.tgz
NetBSD 9.3x86_64gramps-5.1.6nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

freefont
graphviz

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.