databases/p5-DBIx-Introspector - The NetBSD Packages Collection

Detect what database you are connected to

DBIx::Introspector is a module factored out of the DBIx::Class
database detection code. Most code that needs to detect which
database it is connected to assumes that there is a one-to-one
mapping from database drivers to database engines. Unfortunately
reality is rarely that simple. For instance, DBD::ODBC is typically
used to connect to SQL Server, but ODBC can be used to connect
to PostgreSQL, MySQL, and Oracle. Additionally, while ODBC is the
most common way to connect to SQL Server, it is not the only option,
as DBD::ADO can also be used.

Build dependencies

databases/p5-DBD-SQLite devel/p5-Test-Roo pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

databases/p5-DBI devel/p5-Moo lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0aarch64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0aarch64ebp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0aarch64ebp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0alphap5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0alphap5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0earmv4p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0earmv4p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0earmv6hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0earmv6hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0earmv6hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0earmv7hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0earmv7hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0earmv7hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0i386p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0i386p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0i386p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0m68kp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0powerpcp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0powerpcp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0sh3elp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0sparc64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0sparcp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0sparcp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0x86_64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0x86_64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 10.0x86_64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0aarch64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0aarch64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0aarch64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0alphap5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0earmv6hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0earmv6hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0earmv6hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0earmv7hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0earmv7hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0earmv7hfp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0i386p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0i386p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0i386p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0powerpcp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0powerpcp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0powerpcp5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0sparc64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0x86_64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0x86_64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.0x86_64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.3x86_64p5-DBIx-Introspector-0.001005nb8.tgz
NetBSD 9.3x86_64p5-DBIx-Introspector-0.001005nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.