databases/qdbm - The NetBSD Packages Collection

Quick Database Manager - library of routines for managing a db

QDBM is an embeded database library compatible with GDBM and NDBM.  It
features hash database and B+ tree database and is developed referring
to GDBM for the purpose of the following three points: higher
processing speed, smaller size of a database file, and simpler API.

This package includes APIs for C.
APIs for C++, Java, Perl, Ruby and  CGI scripts are provided as separate
package.

Build dependencies

devel/libtool-base pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

archivers/lzo

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64qdbm-1.8.78.tgz
NetBSD 10.0aarch64qdbm-1.8.78.tgz
NetBSD 10.0aarch64qdbm-1.8.78.tgz
NetBSD 10.0aarch64ebqdbm-1.8.78.tgz
NetBSD 10.0aarch64ebqdbm-1.8.78.tgz
NetBSD 10.0alphaqdbm-1.8.78.tgz
NetBSD 10.0earmv4qdbm-1.8.78.tgz
NetBSD 10.0earmv4qdbm-1.8.78.tgz
NetBSD 10.0earmv6hfqdbm-1.8.78.tgz
NetBSD 10.0earmv6hfqdbm-1.8.78.tgz
NetBSD 10.0earmv6hfqdbm-1.8.78.tgz
NetBSD 10.0earmv7hfqdbm-1.8.78.tgz
NetBSD 10.0earmv7hfqdbm-1.8.78.tgz
NetBSD 10.0earmv7hfqdbm-1.8.78.tgz
NetBSD 10.0i386qdbm-1.8.78.tgz
NetBSD 10.0i386qdbm-1.8.78.tgz
NetBSD 10.0m68kqdbm-1.8.78.tgz
NetBSD 10.0m68kqdbm-1.8.78.tgz
NetBSD 10.0powerpcqdbm-1.8.78.tgz
NetBSD 10.0sh3elqdbm-1.8.78.tgz
NetBSD 10.0sparcqdbm-1.8.78.tgz
NetBSD 10.0vaxqdbm-1.8.78.tgz
NetBSD 10.0vaxqdbm-1.8.78.tgz
NetBSD 10.0vaxqdbm-1.8.78.tgz
NetBSD 10.0x86_64qdbm-1.8.78.tgz
NetBSD 10.0_BETAx86_64qdbm-1.8.78.tgz
NetBSD 10.99.4riscv64qdbm-1.8.78.tgz
NetBSD 8.0i386qdbm-1.8.78.tgz
NetBSD 8.0i386qdbm-1.8.78.tgz
NetBSD 8.0i386qdbm-1.8.78.tgz
NetBSD 8.0powerpcqdbm-1.8.78.tgz
NetBSD 8.0powerpcqdbm-1.8.78.tgz
NetBSD 8.0powerpcqdbm-1.8.78.tgz
NetBSD 8.0powerpcqdbm-1.8.78.tgz
NetBSD 8.0x86_64qdbm-1.8.78.tgz
NetBSD 8.0x86_64qdbm-1.8.78.tgz
NetBSD 8.0x86_64qdbm-1.8.78.tgz
NetBSD 9.0aarch64qdbm-1.8.78.tgz
NetBSD 9.0aarch64qdbm-1.8.78.tgz
NetBSD 9.0aarch64qdbm-1.8.78.tgz
NetBSD 9.0alphaqdbm-1.8.78.tgz
NetBSD 9.0alphaqdbm-1.8.78.tgz
NetBSD 9.0earmqdbm-1.8.78.tgz
NetBSD 9.0earmv4qdbm-1.8.78.tgz
NetBSD 9.0earmv4qdbm-1.8.78.tgz
NetBSD 9.0earmv4qdbm-1.8.78.tgz
NetBSD 9.0earmv6hfqdbm-1.8.78.tgz
NetBSD 9.0earmv6hfqdbm-1.8.78.tgz
NetBSD 9.0earmv6hfqdbm-1.8.78.tgz
NetBSD 9.0earmv7hfqdbm-1.8.78.tgz
NetBSD 9.0earmv7hfqdbm-1.8.78.tgz
NetBSD 9.0earmv7hfqdbm-1.8.78.tgz
NetBSD 9.0i386qdbm-1.8.78.tgz
NetBSD 9.0i386qdbm-1.8.78.tgz
NetBSD 9.0m68kqdbm-1.8.78.tgz
NetBSD 9.0mips64ebqdbm-1.8.78.tgz
NetBSD 9.0mipselqdbm-1.8.78.tgz
NetBSD 9.0powerpcqdbm-1.8.78.tgz
NetBSD 9.0powerpcqdbm-1.8.78.tgz
NetBSD 9.0powerpcqdbm-1.8.78.tgz
NetBSD 9.0powerpcqdbm-1.8.78.tgz
NetBSD 9.0sh3elqdbm-1.8.78.tgz
NetBSD 9.0sh3elqdbm-1.8.78.tgz
NetBSD 9.0sparc64qdbm-1.8.78.tgz
NetBSD 9.0sparcqdbm-1.8.78.tgz
NetBSD 9.0sparcqdbm-1.8.78.tgz
NetBSD 9.0vaxqdbm-1.8.78.tgz
NetBSD 9.0vaxqdbm-1.8.78.tgz
NetBSD 9.0x86_64qdbm-1.8.78.tgz
NetBSD 9.0x86_64qdbm-1.8.78.tgz
NetBSD 9.3x86_64qdbm-1.8.78.tgz
NetBSD 9.3x86_64qdbm-1.8.78.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.