devel/dconf - The NetBSD Packages Collection

Backend for gsettings

dconf is a low-level configuration system. Its main purpose is
to provide a backend to GSettings on platforms that don't already
have configuration storage systems.

Build dependencies

textproc/libxslt textproc/docbook-xsl lang/vala pkgtools/cwrappers devel/gdbus-codegen devel/glib2-tools devel/meson lang/python38 devel/pkgconf

Runtime dependencies

devel/glib2 devel/glib2 sysutils/dbus devel/glib2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfdconf-0.36.0nb3.tgz
NetBSD 8.0earmv7hfdconf-0.36.0nb1.tgz
NetBSD 8.0earmv7hfdconf-0.36.0nb3.tgz
NetBSD 8.0i386dconf-0.36.0nb1.tgz
NetBSD 8.0i386dconf-0.36.0nb3.tgz
NetBSD 8.0i386dconf-0.36.0nb3.tgz
NetBSD 8.0x86_64dconf-0.36.0nb1.tgz
NetBSD 8.0x86_64dconf-0.36.0nb3.tgz
NetBSD 9.0aarch64dconf-0.36.0nb3.tgz
NetBSD 9.0aarch64dconf-0.36.0nb1.tgz
NetBSD 9.0aarch64dconf-0.36.0nb3.tgz
NetBSD 9.0alphadconf-0.36.0nb3.tgz
NetBSD 9.0alphadconf-0.36.0nb1.tgz
NetBSD 9.0alphadconf-0.36.0nb3.tgz
NetBSD 9.0earmdconf-0.36.0nb1.tgz
NetBSD 9.0earmdconf-0.36.0nb3.tgz
NetBSD 9.0earmv6hfdconf-0.36.0nb3.tgz
NetBSD 9.0earmv6hfdconf-0.36.0nb1.tgz
NetBSD 9.0earmv6hfdconf-0.36.0nb3.tgz
NetBSD 9.0earmv6hfdconf-0.36.0nb3.tgz
NetBSD 9.0earmv7hfdconf-0.36.0nb3.tgz
NetBSD 9.0earmv7hfdconf-0.36.0nb1.tgz
NetBSD 9.0earmv7hfdconf-0.36.0nb3.tgz
NetBSD 9.0earmv7hfdconf-0.36.0nb3.tgz
NetBSD 9.0i386dconf-0.36.0nb1.tgz
NetBSD 9.0i386dconf-0.36.0nb3.tgz
NetBSD 9.0i386dconf-0.36.0nb3.tgz
NetBSD 9.0mips64ebdconf-0.36.0nb3.tgz
NetBSD 9.0mips64ebdconf-0.36.0nb3.tgz
NetBSD 9.0mipseldconf-0.36.0nb3.tgz
NetBSD 9.0sparc64dconf-0.36.0nb3.tgz
NetBSD 9.0sparc64dconf-0.36.0.tgz
NetBSD 9.0sparc64dconf-0.36.0nb1.tgz
NetBSD 9.0sparc64dconf-0.36.0nb3.tgz
NetBSD 9.0x86_64dconf-0.36.0nb2.tgz
NetBSD 9.0x86_64dconf-0.36.0nb3.tgz
NetBSD 9.0x86_64dconf-0.36.0nb3.tgz
NetBSD 9.0x86_64dconf-0.36.0nb3.tgz
NetBSD 9.0x86_64dconf-0.36.0nb1.tgz
NetBSD 9.0x86_64dconf-0.36.0nb3.tgz
NetBSD 9.0x86_64dconf-0.36.0nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.