devel/dejagnu - The NetBSD Packages Collection

TCL/Expect-based framework for regression testing

  DejaGnu is a framework for testing other programs. Its purpose is to
provide a single front end for all tests.  Beyond this, DejaGnu offers
several advantages for testing:

        - The flexibility and consistency of the DejaGnu framework
          make it easy to write tests for any program.

        - DejaGnu provides a layer of abstraction which makes all
          tests (if correctly written) portable to any host or target
          where a program must be tested.  For instance, a test for
          GDB can run (from any Unix based host) on any target
          architecture supported by DejaGnu. Currently DejaGnu runs
          tests on several single board computers, whose operating
          software ranges from just a boot monitor to a full-fledged,
          Unix-like realtime OS.

        - DejaGnu is written in expect, which in turn uses Tcl
          (Tool command language).  The framework comprises two parts:
          the testing framework and the testsuites themselves. Tests
          are usually written in expect using Tcl.

  Bugs can be reported to bug-dejagnu@gnu.org.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

lang/tcl-expect

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfdejagnu-1.6.2.tgz
NetBSD 8.0earmv7hfdejagnu-1.6.2.tgz
NetBSD 8.0earmv7hfdejagnu-1.6.2.tgz
NetBSD 8.0i386dejagnu-1.6.2.tgz
NetBSD 8.0i386dejagnu-1.6.2.tgz
NetBSD 8.0i386dejagnu-1.6.2.tgz
NetBSD 8.0powerpcdejagnu-1.6.2.tgz
NetBSD 8.0powerpcdejagnu-1.6.2.tgz
NetBSD 8.0powerpcdejagnu-1.6.2.tgz
NetBSD 8.0x86_64dejagnu-1.6.2.tgz
NetBSD 8.0x86_64dejagnu-1.6.2.tgz
NetBSD 9.0aarch64dejagnu-1.6.2.tgz
NetBSD 9.0aarch64dejagnu-1.6.2.tgz
NetBSD 9.0aarch64dejagnu-1.6.2.tgz
NetBSD 9.0alphadejagnu-1.6.2.tgz
NetBSD 9.0alphadejagnu-1.6.2.tgz
NetBSD 9.0alphadejagnu-1.6.2.tgz
NetBSD 9.0earmdejagnu-1.6.2.tgz
NetBSD 9.0earmv6hfdejagnu-1.6.2.tgz
NetBSD 9.0earmv6hfdejagnu-1.6.2.tgz
NetBSD 9.0earmv6hfdejagnu-1.6.2.tgz
NetBSD 9.0earmv6hfdejagnu-1.6.2.tgz
NetBSD 9.0earmv7hfdejagnu-1.6.2.tgz
NetBSD 9.0earmv7hfdejagnu-1.6.2.tgz
NetBSD 9.0earmv7hfdejagnu-1.6.2.tgz
NetBSD 9.0earmv7hfdejagnu-1.6.2.tgz
NetBSD 9.0i386dejagnu-1.6.2.tgz
NetBSD 9.0i386dejagnu-1.6.2.tgz
NetBSD 9.0mips64ebdejagnu-1.6.2.tgz
NetBSD 9.0mips64ebdejagnu-1.6.2.tgz
NetBSD 9.0mips64ebdejagnu-1.6.2.tgz
NetBSD 9.0powerpcdejagnu-1.6.2.tgz
NetBSD 9.0powerpcdejagnu-1.6.2.tgz
NetBSD 9.0sparc64dejagnu-1.6.2.tgz
NetBSD 9.0sparc64dejagnu-1.6.2.tgz
NetBSD 9.0sparc64dejagnu-1.6.2.tgz
NetBSD 9.0sparcdejagnu-1.6.2.tgz
NetBSD 9.0sparcdejagnu-1.6.2.tgz
NetBSD 9.0x86_64dejagnu-1.6.2.tgz
NetBSD 9.0x86_64dejagnu-1.6.2.tgz
NetBSD 9.0x86_64dejagnu-1.6.2.tgz
NetBSD 9.0x86_64dejagnu-1.6.2.tgz
NetBSD 9.0x86_64dejagnu-1.6.2.tgz
NetBSD 9.0x86_64dejagnu-1.6.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.