devel/editline - The NetBSD Packages Collection

NetBSD Editline library (libedit) for generic line editing

This is an autotool- and libtoolized port of the NetBSD Editline library
(libedit). This Berkeley-style licensed command line editor library
provides generic line editing, history, and tokenization functions,
similar to those found in GNU Readline.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfeditline-3.1.20191231nb2.tgz
NetBSD 8.0earmv7hfeditline-3.1.20191231nb1.tgz
NetBSD 8.0earmv7hfeditline-3.1.20191231nb2.tgz
NetBSD 8.0earmv7hfeditline-3.1.20191231nb2.tgz
NetBSD 8.0i386editline-3.1.20191231nb2.tgz
NetBSD 8.0i386editline-3.1.20191231nb2.tgz
NetBSD 8.0i386editline-3.1.20191231nb2.tgz
NetBSD 8.0powerpceditline-3.1.20191231nb2.tgz
NetBSD 8.0powerpceditline-3.1.20191231nb2.tgz
NetBSD 8.0powerpceditline-3.1.20191231nb2.tgz
NetBSD 8.0powerpceditline-3.1.20191231nb2.tgz
NetBSD 8.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 8.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 8.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 9.0aarch64editline-3.1.20191231nb2.tgz
NetBSD 9.0aarch64editline-3.1.20191231nb2.tgz
NetBSD 9.0aarch64editline-3.1.20191231nb2.tgz
NetBSD 9.0aarch64editline-3.1.20191231nb2.tgz
NetBSD 9.0alphaeditline-3.1.20191231nb2.tgz
NetBSD 9.0alphaeditline-3.1.20191231nb2.tgz
NetBSD 9.0alphaeditline-3.1.20191231nb2.tgz
NetBSD 9.0alphaeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmeditline-3.1.20191231nb1.tgz
NetBSD 9.0earmeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv6hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv6hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv6hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv6hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv6hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv7hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv7hfeditline-3.1.20191231nb1.tgz
NetBSD 9.0earmv7hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv7hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv7hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0earmv7hfeditline-3.1.20191231nb2.tgz
NetBSD 9.0i386editline-3.1.20191231nb2.tgz
NetBSD 9.0i386editline-3.1.20191231nb2.tgz
NetBSD 9.0i386editline-3.1.20191231nb2.tgz
NetBSD 9.0m68keditline-3.1.20191231nb1.tgz
NetBSD 9.0m68keditline-3.1.20191231nb2.tgz
NetBSD 9.0mips64ebeditline-3.1.20191231nb2.tgz
NetBSD 9.0mips64ebeditline-3.1.20191231nb2.tgz
NetBSD 9.0mips64ebeditline-3.1.20191231nb2.tgz
NetBSD 9.0mipseleditline-3.1.20191231nb2.tgz
NetBSD 9.0powerpceditline-3.1.20191231nb2.tgz
NetBSD 9.0powerpceditline-3.1.20191231nb2.tgz
NetBSD 9.0powerpceditline-3.1.20191231nb2.tgz
NetBSD 9.0sh3eleditline-3.1.20191231nb2.tgz
NetBSD 9.0sh3eleditline-3.1.20191231nb2.tgz
NetBSD 9.0sh3eleditline-3.1.20191231nb2.tgz
NetBSD 9.0sparc64editline-3.1.20191231nb2.tgz
NetBSD 9.0sparc64editline-3.1.20191231nb2.tgz
NetBSD 9.0sparc64editline-3.1.20191231nb2.tgz
NetBSD 9.0sparc64editline-3.1.20191231nb2.tgz
NetBSD 9.0sparceditline-3.1.20191231nb2.tgz
NetBSD 9.0sparceditline-3.1.20191231nb2.tgz
NetBSD 9.0sparceditline-3.1.20191231nb2.tgz
NetBSD 9.0sparceditline-3.1.20191231nb2.tgz
NetBSD 9.0vaxeditline-3.1.20191231nb2.tgz
NetBSD 9.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 9.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 9.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 9.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 9.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 9.0x86_64editline-3.1.20191231nb2.tgz
NetBSD 9.0x86_64editline-3.1.20191231nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

doc
Include the documentation.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.