devel/flex - The NetBSD Packages Collection

Fast clone of lex(1), the lexical scanner generator

flex is a tool for generating scanners:  programs which recognized
lexical patterns in text.  flex reads the given input files, or its
standard input if no file names are given, for a description of a
scanner to generate.  The description is in the form of pairs of
regular expressions and C code, called rules.  flex generates as
output a C source file, lex.yy.c, which defines a routine yylex().
This file is compiled and linked with the -lfl library to produce an
executable.  When the executable is run, it analyzes its input for
occurrences of the regular expressions.  Whenever it finds one, it
executes the corresponding C code.

Build dependencies

converters/help2man pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

devel/m4

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfflex-2.6.4.tgz
NetBSD 8.0earmv7hfflex-2.6.4.tgz
NetBSD 8.0earmv7hfflex-2.6.4.tgz
NetBSD 8.0i386flex-2.6.4.tgz
NetBSD 8.0i386flex-2.6.4.tgz
NetBSD 8.0i386flex-2.6.4.tgz
NetBSD 8.0powerpcflex-2.6.4.tgz
NetBSD 8.0powerpcflex-2.6.4.tgz
NetBSD 8.0powerpcflex-2.6.4.tgz
NetBSD 8.0x86_64flex-2.6.4.tgz
NetBSD 8.0x86_64flex-2.6.4.tgz
NetBSD 9.0aarch64flex-2.6.4.tgz
NetBSD 9.0aarch64flex-2.6.4.tgz
NetBSD 9.0aarch64flex-2.6.4.tgz
NetBSD 9.0alphaflex-2.6.4.tgz
NetBSD 9.0alphaflex-2.6.4.tgz
NetBSD 9.0alphaflex-2.6.4.tgz
NetBSD 9.0earmflex-2.6.4.tgz
NetBSD 9.0earmflex-2.6.4.tgz
NetBSD 9.0earmflex-2.6.4.tgz
NetBSD 9.0earmv6hfflex-2.6.4.tgz
NetBSD 9.0earmv6hfflex-2.6.4.tgz
NetBSD 9.0earmv6hfflex-2.6.4.tgz
NetBSD 9.0earmv6hfflex-2.6.4.tgz
NetBSD 9.0earmv7hfflex-2.6.4.tgz
NetBSD 9.0earmv7hfflex-2.6.4.tgz
NetBSD 9.0earmv7hfflex-2.6.4.tgz
NetBSD 9.0earmv7hfflex-2.6.4.tgz
NetBSD 9.0i386flex-2.6.4.tgz
NetBSD 9.0i386flex-2.6.4.tgz
NetBSD 9.0i386flex-2.6.4.tgz
NetBSD 9.0m68kflex-2.6.4.tgz
NetBSD 9.0m68kflex-2.6.4.tgz
NetBSD 9.0m68kflex-2.6.4.tgz
NetBSD 9.0mips64ebflex-2.6.4.tgz
NetBSD 9.0mips64ebflex-2.6.4.tgz
NetBSD 9.0mips64ebflex-2.6.4.tgz
NetBSD 9.0mipselflex-2.6.4.tgz
NetBSD 9.0mipselflex-2.6.4.tgz
NetBSD 9.0powerpcflex-2.6.4.tgz
NetBSD 9.0powerpcflex-2.6.4.tgz
NetBSD 9.0sh3elflex-2.6.4.tgz
NetBSD 9.0sh3elflex-2.6.4.tgz
NetBSD 9.0sh3elflex-2.6.4.tgz
NetBSD 9.0sparc64flex-2.6.4.tgz
NetBSD 9.0sparc64flex-2.6.4.tgz
NetBSD 9.0sparc64flex-2.6.4.tgz
NetBSD 9.0sparc64flex-2.6.4.tgz
NetBSD 9.0sparcflex-2.6.4.tgz
NetBSD 9.0sparcflex-2.6.4.tgz
NetBSD 9.0sparcflex-2.6.4.tgz
NetBSD 9.0vaxflex-2.6.4.tgz
NetBSD 9.0vaxflex-2.6.4.tgz
NetBSD 9.0x86_64flex-2.6.4.tgz
NetBSD 9.0x86_64flex-2.6.4.tgz
NetBSD 9.0x86_64flex-2.6.4.tgz
NetBSD 9.0x86_64flex-2.6.4.tgz
NetBSD 9.0x86_64flex-2.6.4.tgz
NetBSD 9.0x86_64flex-2.6.4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.