devel/gflib - The NetBSD Packages Collection

Reed Solomon and Galois Field error correction library

This package contains C procedures for limited Galois Field
arithmetic and Reed-Solomon coding.

Reed-Solomon coding is the error correction coding used in diverse
fields from CDs, DVDs and DAT tapes, to the communications used by
NASA for such missions as Voyager, Voyager II and Cassini Huygens.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgflib-20030604.tgz
NetBSD 8.0earmv7hfgflib-20030604.tgz
NetBSD 8.0earmv7hfgflib-20030604.tgz
NetBSD 8.0i386gflib-20030604.tgz
NetBSD 8.0i386gflib-20030604.tgz
NetBSD 8.0i386gflib-20030604.tgz
NetBSD 8.0powerpcgflib-20030604.tgz
NetBSD 8.0powerpcgflib-20030604.tgz
NetBSD 8.0powerpcgflib-20030604.tgz
NetBSD 8.0x86_64gflib-20030604.tgz
NetBSD 8.0x86_64gflib-20030604.tgz
NetBSD 8.0x86_64gflib-20030604.tgz
NetBSD 9.0aarch64gflib-20030604.tgz
NetBSD 9.0aarch64gflib-20030604.tgz
NetBSD 9.0aarch64gflib-20030604.tgz
NetBSD 9.0alphagflib-20030604.tgz
NetBSD 9.0alphagflib-20030604.tgz
NetBSD 9.0alphagflib-20030604.tgz
NetBSD 9.0earmgflib-20030604.tgz
NetBSD 9.0earmv6hfgflib-20030604.tgz
NetBSD 9.0earmv6hfgflib-20030604.tgz
NetBSD 9.0earmv6hfgflib-20030604.tgz
NetBSD 9.0earmv6hfgflib-20030604.tgz
NetBSD 9.0earmv7hfgflib-20030604.tgz
NetBSD 9.0earmv7hfgflib-20030604.tgz
NetBSD 9.0earmv7hfgflib-20030604.tgz
NetBSD 9.0earmv7hfgflib-20030604.tgz
NetBSD 9.0i386gflib-20030604.tgz
NetBSD 9.0i386gflib-20030604.tgz
NetBSD 9.0i386gflib-20030604.tgz
NetBSD 9.0mips64ebgflib-20030604.tgz
NetBSD 9.0mips64ebgflib-20030604.tgz
NetBSD 9.0mips64ebgflib-20030604.tgz
NetBSD 9.0powerpcgflib-20030604.tgz
NetBSD 9.0powerpcgflib-20030604.tgz
NetBSD 9.0sparc64gflib-20030604.tgz
NetBSD 9.0sparc64gflib-20030604.tgz
NetBSD 9.0sparc64gflib-20030604.tgz
NetBSD 9.0sparc64gflib-20030604.tgz
NetBSD 9.0sparcgflib-20030604.tgz
NetBSD 9.0sparcgflib-20030604.tgz
NetBSD 9.0sparcgflib-20030604.tgz
NetBSD 9.0x86_64gflib-20030604.tgz
NetBSD 9.0x86_64gflib-20030604.tgz
NetBSD 9.0x86_64gflib-20030604.tgz
NetBSD 9.0x86_64gflib-20030604.tgz
NetBSD 9.0x86_64gflib-20030604.tgz
NetBSD 9.0x86_64gflib-20030604.tgz
NetBSD 9.0x86_64gflib-20030604.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.