devel/go-blackfriday - The NetBSD Packages Collection

Blackfriday: a markdown processor for Go

Blackfriday is a Markdown processor implemented in Go. It is paranoid about its
input (so you can safely feed it user-supplied data), it is fast, it supports
common extensions (tables, smart punctuation substitutions, etc.), and it is
safe for all utf-8 (unicode) input.

HTML output is currently supported, along with Smartypants extensions. An
experimental LaTeX output engine is also included.

It started as a translation from C of Sundown.

Build dependencies

lang/go116 devel/go-sanitized_anchor_name pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgo-blackfriday-1.5.1nb22.tgz
NetBSD 8.0earmv7hfgo-blackfriday-1.5.1nb19.tgz
NetBSD 8.0earmv7hfgo-blackfriday-1.5.1nb24.tgz
NetBSD 8.0i386go-blackfriday-1.5.1nb19.tgz
NetBSD 8.0i386go-blackfriday-1.5.1nb22.tgz
NetBSD 8.0i386go-blackfriday-1.5.1nb24.tgz
NetBSD 8.0x86_64go-blackfriday-1.5.1nb24.tgz
NetBSD 8.0x86_64go-blackfriday-1.5.1nb19.tgz
NetBSD 9.0aarch64go-blackfriday-1.5.1nb24.tgz
NetBSD 9.0aarch64go-blackfriday-1.5.1nb19.tgz
NetBSD 9.0aarch64go-blackfriday-1.5.1nb22.tgz
NetBSD 9.0earmv7hfgo-blackfriday-1.5.1nb24.tgz
NetBSD 9.0earmv7hfgo-blackfriday-1.5.1nb19.tgz
NetBSD 9.0earmv7hfgo-blackfriday-1.5.1nb22.tgz
NetBSD 9.0i386go-blackfriday-1.5.1nb19.tgz
NetBSD 9.0i386go-blackfriday-1.5.1nb22.tgz
NetBSD 9.0i386go-blackfriday-1.5.1nb24.tgz
NetBSD 9.0x86_64go-blackfriday-1.5.1nb22.tgz
NetBSD 9.0x86_64go-blackfriday-1.5.1nb22.tgz
NetBSD 9.0x86_64go-blackfriday-1.5.1nb23.tgz
NetBSD 9.0x86_64go-blackfriday-1.5.1nb24.tgz
NetBSD 9.0x86_64go-blackfriday-1.5.1nb19.tgz
NetBSD 9.0x86_64go-blackfriday-1.5.1nb22.tgz
NetBSD 9.0x86_64go-blackfriday-1.5.1nb24.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.