devel/go-glog - The NetBSD Packages Collection

Leveled execution logs for Go

Package glog implements logging analogous to the Google-internal
C++ INFO/ERROR/V setup.  It provides functions Info, Warning,
Error, Fatal, plus formatting variants such as Infof. It
also provides V-style logging controlled by the -v and
-vmodule=file=2 flags.

This is an efficient pure Go implementation of leveled logs in the
manner of the open source C++ package
	https://github.com/google/glog
	(pkgsrc/devel/google-glog)

By binding methods to booleans it is possible to use the log package
without paying the expense of evaluating the arguments to the log.
Through the -vmodule flag, the package also provides fine-grained
control over logging at the file level.

Build dependencies

lang/go116 pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgo-glog-20160125nb28.tgz
NetBSD 8.0earmv7hfgo-glog-20160125nb25.tgz
NetBSD 8.0earmv7hfgo-glog-20160125nb30.tgz
NetBSD 8.0i386go-glog-20160125nb25.tgz
NetBSD 8.0i386go-glog-20160125nb28.tgz
NetBSD 8.0x86_64go-glog-20160125nb25.tgz
NetBSD 9.0aarch64go-glog-20160125nb30.tgz
NetBSD 9.0aarch64go-glog-20160125nb25.tgz
NetBSD 9.0aarch64go-glog-20160125nb28.tgz
NetBSD 9.0earmv7hfgo-glog-20160125nb30.tgz
NetBSD 9.0earmv7hfgo-glog-20160125nb25.tgz
NetBSD 9.0earmv7hfgo-glog-20160125nb28.tgz
NetBSD 9.0i386go-glog-20160125nb25.tgz
NetBSD 9.0i386go-glog-20160125nb28.tgz
NetBSD 9.0x86_64go-glog-20160125nb28.tgz
NetBSD 9.0x86_64go-glog-20160125nb28.tgz
NetBSD 9.0x86_64go-glog-20160125nb29.tgz
NetBSD 9.0x86_64go-glog-20160125nb25.tgz
NetBSD 9.0x86_64go-glog-20160125nb28.tgz
NetBSD 9.0x86_64go-glog-20160125nb30.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.