devel/go-mapstructure - The NetBSD Packages Collection

Library for decoding generic map values into native structures

mapstructure is a Go library for decoding generic map values to structures and
vice versa, while providing helpful error handling.

This library is most useful when decoding values from some data stream (JSON,
Gob, etc.) where you don't quite know the structure of the underlying data
until you read a part of it. You can therefore read a map[string]interface{}
and use this library to decode it into the proper underlying native Go
structure.

Build dependencies

lang/go116 pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgo-mapstructure-0.0.20160212nb25.tgz
NetBSD 8.0earmv7hfgo-mapstructure-0.0.20160212nb22.tgz
NetBSD 8.0earmv7hfgo-mapstructure-0.0.20160212nb27.tgz
NetBSD 8.0i386go-mapstructure-0.0.20160212nb22.tgz
NetBSD 8.0i386go-mapstructure-0.0.20160212nb25.tgz
NetBSD 8.0i386go-mapstructure-0.0.20160212nb27.tgz
NetBSD 8.0x86_64go-mapstructure-0.0.20160212nb22.tgz
NetBSD 9.0aarch64go-mapstructure-0.0.20160212nb27.tgz
NetBSD 9.0aarch64go-mapstructure-0.0.20160212nb22.tgz
NetBSD 9.0aarch64go-mapstructure-0.0.20160212nb25.tgz
NetBSD 9.0earmv7hfgo-mapstructure-0.0.20160212nb27.tgz
NetBSD 9.0earmv7hfgo-mapstructure-0.0.20160212nb22.tgz
NetBSD 9.0earmv7hfgo-mapstructure-0.0.20160212nb25.tgz
NetBSD 9.0i386go-mapstructure-0.0.20160212nb22.tgz
NetBSD 9.0i386go-mapstructure-0.0.20160212nb25.tgz
NetBSD 9.0i386go-mapstructure-0.0.20160212nb27.tgz
NetBSD 9.0x86_64go-mapstructure-0.0.20160212nb25.tgz
NetBSD 9.0x86_64go-mapstructure-0.0.20160212nb25.tgz
NetBSD 9.0x86_64go-mapstructure-0.0.20160212nb26.tgz
NetBSD 9.0x86_64go-mapstructure-0.0.20160212nb22.tgz
NetBSD 9.0x86_64go-mapstructure-0.0.20160212nb25.tgz
NetBSD 9.0x86_64go-mapstructure-0.0.20160212nb27.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.