devel/go-sys - The NetBSD Packages Collection

Go packages for low-level interaction with the OS

This repository holds supplemental Go packages for low-level
interactions with the operating system.

Build dependencies

lang/go116 pkgtools/cwrappers

Runtime dependencies

shells/bash lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgo-sys-0.0.20200202nb11.tgz
NetBSD 8.0earmv7hfgo-sys-0.0.20200202nb8.tgz
NetBSD 8.0earmv7hfgo-sys-0.0.20200202nb13.tgz
NetBSD 8.0i386go-sys-0.0.20200202nb8.tgz
NetBSD 8.0i386go-sys-0.0.20200202nb11.tgz
NetBSD 8.0i386go-sys-0.0.20200202nb13.tgz
NetBSD 8.0x86_64go-sys-0.0.20200202nb13.tgz
NetBSD 8.0x86_64go-sys-0.0.20200202nb8.tgz
NetBSD 9.0aarch64go-sys-0.0.20200202nb13.tgz
NetBSD 9.0aarch64go-sys-0.0.20200202nb8.tgz
NetBSD 9.0aarch64go-sys-0.0.20200202nb11.tgz
NetBSD 9.0earmv7hfgo-sys-0.0.20200202nb13.tgz
NetBSD 9.0earmv7hfgo-sys-0.0.20200202nb8.tgz
NetBSD 9.0earmv7hfgo-sys-0.0.20200202nb11.tgz
NetBSD 9.0i386go-sys-0.0.20200202nb8.tgz
NetBSD 9.0i386go-sys-0.0.20200202nb11.tgz
NetBSD 9.0i386go-sys-0.0.20200202nb13.tgz
NetBSD 9.0x86_64go-sys-0.0.20200202nb11.tgz
NetBSD 9.0x86_64go-sys-0.0.20200202nb11.tgz
NetBSD 9.0x86_64go-sys-0.0.20200202nb12.tgz
NetBSD 9.0x86_64go-sys-0.0.20200202nb13.tgz
NetBSD 9.0x86_64go-sys-0.0.20200202nb8.tgz
NetBSD 9.0x86_64go-sys-0.0.20200202nb11.tgz
NetBSD 9.0x86_64go-sys-0.0.20200202nb13.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.