devel/go-termbox - The NetBSD Packages Collection

Pure Go termbox implementation

Termbox is a library that provides a minimalistic API which allows the
programmer to write text-based user interfaces. The library is crossplatform
and has both terminal-based implementations on *nix operating systems and a
winapi console based implementation for windows operating systems. The basic
idea is an abstraction of the greatest common subset of features available on
all major terminals and other terminal-like APIs in a minimalistic fashion.
Small API means it is easy to implement, test, maintain and learn it, that's
what makes the termbox a distinct library in its area.

Build dependencies

lang/go116 textproc/go-runewidth pkgtools/cwrappers

Runtime dependencies

lang/python38 lang/python38

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgo-termbox-20160808nb31.tgz
NetBSD 8.0earmv7hfgo-termbox-20160808nb27.tgz
NetBSD 8.0earmv7hfgo-termbox-20160808nb33.tgz
NetBSD 8.0i386go-termbox-20160808nb27.tgz
NetBSD 8.0i386go-termbox-20160808nb31.tgz
NetBSD 8.0i386go-termbox-20160808nb33.tgz
NetBSD 8.0x86_64go-termbox-20160808nb33.tgz
NetBSD 8.0x86_64go-termbox-20160808nb27.tgz
NetBSD 9.0aarch64go-termbox-20160808nb33.tgz
NetBSD 9.0aarch64go-termbox-20160808nb27.tgz
NetBSD 9.0aarch64go-termbox-20160808nb31.tgz
NetBSD 9.0earmv7hfgo-termbox-20160808nb33.tgz
NetBSD 9.0earmv7hfgo-termbox-20160808nb27.tgz
NetBSD 9.0earmv7hfgo-termbox-20160808nb31.tgz
NetBSD 9.0earmv7hfgo-termbox-20160808nb33.tgz
NetBSD 9.0i386go-termbox-20160808nb27.tgz
NetBSD 9.0i386go-termbox-20160808nb31.tgz
NetBSD 9.0i386go-termbox-20160808nb33.tgz
NetBSD 9.0x86_64go-termbox-20160808nb30.tgz
NetBSD 9.0x86_64go-termbox-20160808nb31.tgz
NetBSD 9.0x86_64go-termbox-20160808nb32.tgz
NetBSD 9.0x86_64go-termbox-20160808nb33.tgz
NetBSD 9.0x86_64go-termbox-20160808nb27.tgz
NetBSD 9.0x86_64go-termbox-20160808nb31.tgz
NetBSD 9.0x86_64go-termbox-20160808nb33.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.