devel/go-viper - The NetBSD Packages Collection

Go configuration with fangs

Go configuration with fangs!

Many Go projects are built using Viper including:

* Hugo
* EMC RexRay
* Imgur's Incus
* Nanobox/Nanopack
* Docker Notary
* BloomApi

* DOIt

Build dependencies

lang/go116 www/go-toml-pelletier devel/go-buffruneio devel/go-fsnotify lang/go-hcl devel/go-properties devel/go-mapstructure devel/go-cast devel/go-jwalterweatherman devel/go-pflag devel/go-yaml devel/go-sys devel/go-consul-api databases/go-etcd security/go-crypt security/go-crypto devel/go-afero textproc/go-text security/go-sftp devel/go-fs devel/go-errors pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgo-viper-1.3.1nb20.tgz
NetBSD 8.0earmv7hfgo-viper-1.3.1nb17.tgz
NetBSD 8.0earmv7hfgo-viper-1.3.1nb22.tgz
NetBSD 8.0i386go-viper-1.3.1nb17.tgz
NetBSD 8.0i386go-viper-1.3.1nb20.tgz
NetBSD 8.0i386go-viper-1.3.1nb22.tgz
NetBSD 8.0x86_64go-viper-1.3.1nb17.tgz
NetBSD 9.0aarch64go-viper-1.3.1nb22.tgz
NetBSD 9.0aarch64go-viper-1.3.1nb17.tgz
NetBSD 9.0aarch64go-viper-1.3.1nb20.tgz
NetBSD 9.0earmv7hfgo-viper-1.3.1nb22.tgz
NetBSD 9.0earmv7hfgo-viper-1.3.1nb17.tgz
NetBSD 9.0earmv7hfgo-viper-1.3.1nb20.tgz
NetBSD 9.0i386go-viper-1.3.1nb17.tgz
NetBSD 9.0i386go-viper-1.3.1nb20.tgz
NetBSD 9.0x86_64go-viper-1.3.1nb20.tgz
NetBSD 9.0x86_64go-viper-1.3.1nb20.tgz
NetBSD 9.0x86_64go-viper-1.3.1nb21.tgz
NetBSD 9.0x86_64go-viper-1.3.1nb17.tgz
NetBSD 9.0x86_64go-viper-1.3.1nb20.tgz
NetBSD 9.0x86_64go-viper-1.3.1nb22.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.