devel/hs-base-compat - The NetBSD Packages Collection

Compatibility layer for base

Provides functions available in later versions of base to a wider
range of compilers, without requiring you to use CPP pragmas in your
code. See the README for what is covered. Also see the changelog for
recent changes.

Note that base-compat does not add any orphan instances. There is a
separate package, base-orphans, for that.

In addition, base-compat does not backport any data types or type
classes. See this section of the README for more info.

base-compat is designed to have zero dependencies. For a version of
base-compat that depends on compatibility libraries for a wider
support window, see the base-compat-batteries package. Most of the
modules in this library have the same names as in
base-compat-batteries to make it easier to switch between the
two. There also exist versions of each module with the suffix .Repl,
which are distinct from anything in base-compat-batteries, to allow
for easier use in GHCi.

Build dependencies

pkgtools/cwrappers devel/pkgconf

Runtime dependencies

lang/ghc88 lang/ghc88

Binary packages

OSArchitectureVersion
NetBSD 8.0x86_64hs-base-compat-0.11.0.tgz
NetBSD 8.0x86_64hs-base-compat-0.11.0.tgz
NetBSD 9.0x86_64hs-base-compat-0.11.0.tgz
NetBSD 9.0x86_64hs-base-compat-0.11.0.tgz
NetBSD 9.0x86_64hs-base-compat-0.11.0.tgz
NetBSD 9.0x86_64hs-base-compat-0.11.0.tgz
NetBSD 9.0x86_64hs-base-compat-0.11.0.tgz
NetBSD 9.0x86_64hs-base-compat-0.11.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.