devel/hs-blaze-builder - The NetBSD Packages Collection

Efficient buffered output

This library provides an implementation of the older blaze-builder
interface in terms of the new builder that shipped with
bytestring-0.10.4.0

This implementation is mostly intended as a bridge to the new builder,
so that code that uses the old interface can interoperate with code
that uses the new implementation. Note that no attempt has been made
to preserve the old internal modules, so code that has these
dependencies cannot use this interface.

New code should, for the most part, use the new interface. However,
this module does implement a chunked HTTP encoding, which is not
otherwise implemented (yet?) with the new builder.

Build dependencies

pkgtools/cwrappers devel/pkgconf

Runtime dependencies

lang/ghc88 lang/ghc88

Binary packages

OSArchitectureVersion
NetBSD 8.0x86_64hs-blaze-builder-0.4.1.0.tgz
NetBSD 8.0x86_64hs-blaze-builder-0.4.1.0.tgz
NetBSD 9.0x86_64hs-blaze-builder-0.4.1.0.tgz
NetBSD 9.0x86_64hs-blaze-builder-0.4.1.0.tgz
NetBSD 9.0x86_64hs-blaze-builder-0.4.1.0.tgz
NetBSD 9.0x86_64hs-blaze-builder-0.4.1.0.tgz
NetBSD 9.0x86_64hs-blaze-builder-0.4.1.0.tgz
NetBSD 9.0x86_64hs-blaze-builder-0.4.1.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.