devel/kservice - The NetBSD Packages Collection

Advanced plugin and service introspection

KService provides a plugin framework for handling desktop services. Services can
be applications or libraries. They can be bound to MIME types or handled by
application specific code.

Build dependencies

devel/extra-cmake-modules devel/extra-cmake-modules devel/kdoctools pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/bison devel/cmake devel/cmake

Runtime dependencies

lang/python38 lang/python38 devel/kconfig x11/qt5-qtbase devel/kcrash devel/ki18n sysutils/kdbusaddons devel/kconfig x11/qt5-qtbase devel/kcrash sysutils/kdbusaddons

Binary packages

OSArchitectureVersion
NetBSD 8.0i386kservice-5.70.0nb1.tgz
NetBSD 8.0powerpckservice-5.70.0nb1.tgz
NetBSD 8.0x86_64kservice-5.70.0nb2.tgz
NetBSD 8.0x86_64kservice-5.70.0nb1.tgz
NetBSD 8.0x86_64kservice-5.70.0nb2.tgz
NetBSD 9.0aarch64kservice-5.70.0nb2.tgz
NetBSD 9.0aarch64kservice-5.70.0nb1.tgz
NetBSD 9.0aarch64kservice-5.70.0nb2.tgz
NetBSD 9.0earmv7hfkservice-5.70.0nb1.tgz
NetBSD 9.0i386kservice-5.70.0nb1.tgz
NetBSD 9.0i386kservice-5.70.0nb2.tgz
NetBSD 9.0i386kservice-5.70.0nb2.tgz
NetBSD 9.0powerpckservice-5.70.0nb2.tgz
NetBSD 9.0sparc64kservice-5.70.0nb2.tgz
NetBSD 9.0sparc64kservice-5.70.0.tgz
NetBSD 9.0sparc64kservice-5.70.0nb1.tgz
NetBSD 9.0x86_64kservice-5.70.0nb2.tgz
NetBSD 9.0x86_64kservice-5.70.0nb2.tgz
NetBSD 9.0x86_64kservice-5.70.0nb2.tgz
NetBSD 9.0x86_64kservice-5.70.0nb1.tgz
NetBSD 9.0x86_64kservice-5.70.0nb2.tgz
NetBSD 9.0x86_64kservice-5.70.0nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.