devel/libappindicator - The NetBSD Packages Collection

Allow applications to export a menu into the panel

A library to allow applications to export a menu into the Unity Menu bar. Based
on KSNI it also works in KDE and will fallback to generic Systray support if
none of those are available.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto lang/python27 x11/py-gtk2 devel/py-gobject-shared pkgtools/cwrappers lang/python27 x11/py-gtk2 devel/py-gobject-shared devel/glib2-tools devel/libtool-base devel/gmake archivers/gtar-base devel/pkgconf

Runtime dependencies

devel/libindicator x11/gtk3 devel/libdbusmenu-gtk3 sysutils/dbus-glib devel/libindicator x11/gtk3 devel/libdbusmenu-gtk3 sysutils/dbus-glib

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibappindicator-12.10.0nb8.tgz
NetBSD 8.0earmv7hflibappindicator-12.10.0nb8.tgz
NetBSD 8.0i386libappindicator-12.10.0nb6.tgz
NetBSD 8.0i386libappindicator-12.10.0nb8.tgz
NetBSD 8.0i386libappindicator-12.10.0nb8.tgz
NetBSD 8.0x86_64libappindicator-12.10.0nb8.tgz
NetBSD 8.0x86_64libappindicator-12.10.0nb6.tgz
NetBSD 8.0x86_64libappindicator-12.10.0nb8.tgz
NetBSD 9.0aarch64libappindicator-12.10.0nb8.tgz
NetBSD 9.0aarch64libappindicator-12.10.0nb6.tgz
NetBSD 9.0aarch64libappindicator-12.10.0nb8.tgz
NetBSD 9.0alphalibappindicator-12.10.0nb8.tgz
NetBSD 9.0alphalibappindicator-12.10.0nb6.tgz
NetBSD 9.0alphalibappindicator-12.10.0nb8.tgz
NetBSD 9.0earmlibappindicator-12.10.0nb8.tgz
NetBSD 9.0earmv6hflibappindicator-12.10.0nb8.tgz
NetBSD 9.0earmv6hflibappindicator-12.10.0nb6.tgz
NetBSD 9.0earmv6hflibappindicator-12.10.0nb8.tgz
NetBSD 9.0earmv6hflibappindicator-12.10.0nb8.tgz
NetBSD 9.0earmv7hflibappindicator-12.10.0nb8.tgz
NetBSD 9.0earmv7hflibappindicator-12.10.0nb6.tgz
NetBSD 9.0earmv7hflibappindicator-12.10.0nb8.tgz
NetBSD 9.0earmv7hflibappindicator-12.10.0nb8.tgz
NetBSD 9.0earmv7hflibappindicator-12.10.0nb8.tgz
NetBSD 9.0i386libappindicator-12.10.0nb6.tgz
NetBSD 9.0i386libappindicator-12.10.0nb8.tgz
NetBSD 9.0i386libappindicator-12.10.0nb8.tgz
NetBSD 9.0mips64eblibappindicator-12.10.0nb8.tgz
NetBSD 9.0mips64eblibappindicator-12.10.0nb8.tgz
NetBSD 9.0sparc64libappindicator-12.10.0nb8.tgz
NetBSD 9.0sparc64libappindicator-12.10.0nb5.tgz
NetBSD 9.0sparc64libappindicator-12.10.0nb6.tgz
NetBSD 9.0sparc64libappindicator-12.10.0nb8.tgz
NetBSD 9.0x86_64libappindicator-12.10.0nb7.tgz
NetBSD 9.0x86_64libappindicator-12.10.0nb8.tgz
NetBSD 9.0x86_64libappindicator-12.10.0nb8.tgz
NetBSD 9.0x86_64libappindicator-12.10.0nb8.tgz
NetBSD 9.0x86_64libappindicator-12.10.0nb6.tgz
NetBSD 9.0x86_64libappindicator-12.10.0nb8.tgz
NetBSD 9.0x86_64libappindicator-12.10.0nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.