devel/libnet11 - The NetBSD Packages Collection

C library for portable packet creation and injection

Libnet is a high-level API (toolkit) allowing the application programmer to
construct and inject network packets. It provides a portable and simplified
interface for low-level network packet shaping, handling and injection.
Libnet hides much of the tedium of packet creation from the application
programmer such as multiplexing, buffer management, arcane packet header
information, byte-ordering, OS-dependent issues, and much more. Libnet
features portable packet creation interfaces at the IP layer and link layer,
as well as a host of supplementary and complementary functionality.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibnet11-1.1.2.1.tgz
NetBSD 8.0earmv7hflibnet11-1.1.2.1.tgz
NetBSD 8.0earmv7hflibnet11-1.1.2.1.tgz
NetBSD 8.0i386libnet11-1.1.2.1.tgz
NetBSD 8.0i386libnet11-1.1.2.1.tgz
NetBSD 8.0i386libnet11-1.1.2.1.tgz
NetBSD 8.0powerpclibnet11-1.1.2.1.tgz
NetBSD 8.0powerpclibnet11-1.1.2.1.tgz
NetBSD 8.0powerpclibnet11-1.1.2.1.tgz
NetBSD 8.0x86_64libnet11-1.1.2.1.tgz
NetBSD 8.0x86_64libnet11-1.1.2.1.tgz
NetBSD 9.0aarch64libnet11-1.1.2.1.tgz
NetBSD 9.0aarch64libnet11-1.1.2.1.tgz
NetBSD 9.0aarch64libnet11-1.1.2.1.tgz
NetBSD 9.0alphalibnet11-1.1.2.1.tgz
NetBSD 9.0alphalibnet11-1.1.2.1.tgz
NetBSD 9.0alphalibnet11-1.1.2.1.tgz
NetBSD 9.0earmlibnet11-1.1.2.1.tgz
NetBSD 9.0earmlibnet11-1.1.2.1.tgz
NetBSD 9.0earmlibnet11-1.1.2.1.tgz
NetBSD 9.0earmv6hflibnet11-1.1.2.1.tgz
NetBSD 9.0earmv6hflibnet11-1.1.2.1.tgz
NetBSD 9.0earmv6hflibnet11-1.1.2.1.tgz
NetBSD 9.0earmv6hflibnet11-1.1.2.1.tgz
NetBSD 9.0earmv7hflibnet11-1.1.2.1.tgz
NetBSD 9.0earmv7hflibnet11-1.1.2.1.tgz
NetBSD 9.0earmv7hflibnet11-1.1.2.1.tgz
NetBSD 9.0earmv7hflibnet11-1.1.2.1.tgz
NetBSD 9.0i386libnet11-1.1.2.1.tgz
NetBSD 9.0i386libnet11-1.1.2.1.tgz
NetBSD 9.0i386libnet11-1.1.2.1.tgz
NetBSD 9.0m68klibnet11-1.1.2.1.tgz
NetBSD 9.0mips64eblibnet11-1.1.2.1.tgz
NetBSD 9.0mips64eblibnet11-1.1.2.1.tgz
NetBSD 9.0mips64eblibnet11-1.1.2.1.tgz
NetBSD 9.0mipsellibnet11-1.1.2.1.tgz
NetBSD 9.0mipsellibnet11-1.1.2.1.tgz
NetBSD 9.0powerpclibnet11-1.1.2.1.tgz
NetBSD 9.0powerpclibnet11-1.1.2.1.tgz
NetBSD 9.0sh3ellibnet11-1.1.2.1.tgz
NetBSD 9.0sh3ellibnet11-1.1.2.1.tgz
NetBSD 9.0sparc64libnet11-1.1.2.1.tgz
NetBSD 9.0sparc64libnet11-1.1.2.1.tgz
NetBSD 9.0sparc64libnet11-1.1.2.1.tgz
NetBSD 9.0sparc64libnet11-1.1.2.1.tgz
NetBSD 9.0sparclibnet11-1.1.2.1.tgz
NetBSD 9.0sparclibnet11-1.1.2.1.tgz
NetBSD 9.0sparclibnet11-1.1.2.1.tgz
NetBSD 9.0vaxlibnet11-1.1.2.1.tgz
NetBSD 9.0vaxlibnet11-1.1.2.1.tgz
NetBSD 9.0x86_64libnet11-1.1.2.1.tgz
NetBSD 9.0x86_64libnet11-1.1.2.1.tgz
NetBSD 9.0x86_64libnet11-1.1.2.1.tgz
NetBSD 9.0x86_64libnet11-1.1.2.1.tgz
NetBSD 9.0x86_64libnet11-1.1.2.1.tgz
NetBSD 9.0x86_64libnet11-1.1.2.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.