devel/libslang2 - The NetBSD Packages Collection

Routines for rapid alpha-numeric terminal applications development

S-Lang is a C programmer's library that includes routines for the rapid
development of sophisticated, user friendly, multi-platform applications.

The S-Lang library includes the following:

 -	Low level tty input routines for reading single characters at a
	time, as well as low-level terminal-independent routines for
	manipulating the display of a terminal.

 - 	Keymap routines for defining keys and manipulating multiple
	keymaps.

 -	High level screen management routines for manipulating both
 	monochrome and color terminals.  These routines are very efficient.

 -	Routines for reading single line input with line editing and recall
	capabilities.

 -	Searching functions: both ordinary searches and regular expression
	searches.

 -	An embedded stack-based language interpreter with a C-like syntax.

 -	A malloc debugging package

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 8.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 8.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 8.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 8.0i386libslang2-2.2.4nb3.tgz
NetBSD 8.0i386libslang2-2.2.4nb3.tgz
NetBSD 8.0i386libslang2-2.2.4nb3.tgz
NetBSD 8.0powerpclibslang2-2.2.4nb3.tgz
NetBSD 8.0powerpclibslang2-2.2.4nb3.tgz
NetBSD 8.0powerpclibslang2-2.2.4nb3.tgz
NetBSD 8.0powerpclibslang2-2.2.4nb3.tgz
NetBSD 8.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 8.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 8.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 9.0aarch64libslang2-2.2.4nb3.tgz
NetBSD 9.0aarch64libslang2-2.2.4nb3.tgz
NetBSD 9.0aarch64libslang2-2.2.4nb3.tgz
NetBSD 9.0aarch64libslang2-2.2.4nb3.tgz
NetBSD 9.0alphalibslang2-2.2.4nb3.tgz
NetBSD 9.0alphalibslang2-2.2.4nb3.tgz
NetBSD 9.0alphalibslang2-2.2.4nb3.tgz
NetBSD 9.0alphalibslang2-2.2.4nb3.tgz
NetBSD 9.0earmlibslang2-2.2.4nb3.tgz
NetBSD 9.0earmlibslang2-2.2.4nb3.tgz
NetBSD 9.0earmlibslang2-2.2.4nb3.tgz
NetBSD 9.0earmlibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv6hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv6hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv6hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv6hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv6hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 9.0earmv7hflibslang2-2.2.4nb3.tgz
NetBSD 9.0i386libslang2-2.2.4nb3.tgz
NetBSD 9.0i386libslang2-2.2.4nb3.tgz
NetBSD 9.0i386libslang2-2.2.4nb3.tgz
NetBSD 9.0m68klibslang2-2.2.4nb3.tgz
NetBSD 9.0mips64eblibslang2-2.2.4nb3.tgz
NetBSD 9.0mips64eblibslang2-2.2.4nb3.tgz
NetBSD 9.0mips64eblibslang2-2.2.4nb3.tgz
NetBSD 9.0mipsellibslang2-2.2.4nb3.tgz
NetBSD 9.0mipsellibslang2-2.2.4nb3.tgz
NetBSD 9.0powerpclibslang2-2.2.4nb3.tgz
NetBSD 9.0powerpclibslang2-2.2.4nb3.tgz
NetBSD 9.0powerpclibslang2-2.2.4nb3.tgz
NetBSD 9.0sh3ellibslang2-2.2.4nb3.tgz
NetBSD 9.0sh3ellibslang2-2.2.4nb3.tgz
NetBSD 9.0sparc64libslang2-2.2.4nb3.tgz
NetBSD 9.0sparc64libslang2-2.2.4nb3.tgz
NetBSD 9.0sparc64libslang2-2.2.4nb3.tgz
NetBSD 9.0sparc64libslang2-2.2.4nb3.tgz
NetBSD 9.0sparclibslang2-2.2.4nb3.tgz
NetBSD 9.0sparclibslang2-2.2.4nb3.tgz
NetBSD 9.0sparclibslang2-2.2.4nb3.tgz
NetBSD 9.0sparclibslang2-2.2.4nb3.tgz
NetBSD 9.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 9.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 9.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 9.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 9.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 9.0x86_64libslang2-2.2.4nb3.tgz
NetBSD 9.0x86_64libslang2-2.2.4nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

oniguruma
Support regular expressions via the oniguruma library.
pcre
Enable Perl-compatible regular expressions.
png
Enable PNG support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.