devel/libsmi - The NetBSD Packages Collection

Library to access SMI MIB information

The purpose of libsmi is to

- give network management applications a concise programmer-friendly interface
  to access MIB module information,
- separate the knowledge on SMI from the main parts of management applications,
- allow to add new kinds of MIB repositories without the need to adapt
  applications that make use of libsmi.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

net/wget

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibsmi-0.5.0.tgz
NetBSD 8.0earmv7hflibsmi-0.5.0.tgz
NetBSD 8.0earmv7hflibsmi-0.5.0.tgz
NetBSD 8.0i386libsmi-0.5.0.tgz
NetBSD 8.0i386libsmi-0.5.0.tgz
NetBSD 8.0i386libsmi-0.5.0.tgz
NetBSD 8.0powerpclibsmi-0.5.0.tgz
NetBSD 8.0powerpclibsmi-0.5.0.tgz
NetBSD 8.0powerpclibsmi-0.5.0.tgz
NetBSD 8.0x86_64libsmi-0.5.0.tgz
NetBSD 8.0x86_64libsmi-0.5.0.tgz
NetBSD 9.0aarch64libsmi-0.5.0.tgz
NetBSD 9.0aarch64libsmi-0.5.0.tgz
NetBSD 9.0aarch64libsmi-0.5.0.tgz
NetBSD 9.0alphalibsmi-0.5.0.tgz
NetBSD 9.0alphalibsmi-0.5.0.tgz
NetBSD 9.0alphalibsmi-0.5.0.tgz
NetBSD 9.0earmlibsmi-0.5.0.tgz
NetBSD 9.0earmv6hflibsmi-0.5.0.tgz
NetBSD 9.0earmv6hflibsmi-0.5.0.tgz
NetBSD 9.0earmv6hflibsmi-0.5.0.tgz
NetBSD 9.0earmv6hflibsmi-0.5.0.tgz
NetBSD 9.0earmv7hflibsmi-0.5.0.tgz
NetBSD 9.0earmv7hflibsmi-0.5.0.tgz
NetBSD 9.0earmv7hflibsmi-0.5.0.tgz
NetBSD 9.0earmv7hflibsmi-0.5.0.tgz
NetBSD 9.0i386libsmi-0.5.0.tgz
NetBSD 9.0i386libsmi-0.5.0.tgz
NetBSD 9.0i386libsmi-0.5.0.tgz
NetBSD 9.0mips64eblibsmi-0.5.0.tgz
NetBSD 9.0mips64eblibsmi-0.5.0.tgz
NetBSD 9.0mips64eblibsmi-0.5.0.tgz
NetBSD 9.0powerpclibsmi-0.5.0.tgz
NetBSD 9.0powerpclibsmi-0.5.0.tgz
NetBSD 9.0sparc64libsmi-0.5.0.tgz
NetBSD 9.0sparc64libsmi-0.5.0.tgz
NetBSD 9.0sparc64libsmi-0.5.0.tgz
NetBSD 9.0sparc64libsmi-0.5.0.tgz
NetBSD 9.0sparclibsmi-0.5.0.tgz
NetBSD 9.0sparclibsmi-0.5.0.tgz
NetBSD 9.0sparclibsmi-0.5.0.tgz
NetBSD 9.0x86_64libsmi-0.5.0.tgz
NetBSD 9.0x86_64libsmi-0.5.0.tgz
NetBSD 9.0x86_64libsmi-0.5.0.tgz
NetBSD 9.0x86_64libsmi-0.5.0.tgz
NetBSD 9.0x86_64libsmi-0.5.0.tgz
NetBSD 9.0x86_64libsmi-0.5.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.