devel/libtecla - The NetBSD Packages Collection

Interactive command line editing facilities

The tecla library provides UNIX and LINUX programs with interactive
command line editing facilities, similar to those of the UNIX tcsh
shell. In addition to simple command-line editing, it supports recall
of previously entered command lines, TAB completion of file names or
other tokens, and in-line wild-card expansion of filenames. The
internal functions which perform file-name completion and wild-card
expansion are also available externally for optional use by programs.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibtecla-1.6.1nb4.tgz
NetBSD 8.0earmv7hflibtecla-1.6.1nb4.tgz
NetBSD 8.0earmv7hflibtecla-1.6.1nb4.tgz
NetBSD 8.0i386libtecla-1.6.1nb4.tgz
NetBSD 8.0i386libtecla-1.6.1nb4.tgz
NetBSD 8.0i386libtecla-1.6.1nb4.tgz
NetBSD 8.0powerpclibtecla-1.6.1nb4.tgz
NetBSD 8.0powerpclibtecla-1.6.1nb4.tgz
NetBSD 8.0powerpclibtecla-1.6.1nb4.tgz
NetBSD 8.0x86_64libtecla-1.6.1nb4.tgz
NetBSD 8.0x86_64libtecla-1.6.1nb4.tgz
NetBSD 9.0aarch64libtecla-1.6.1nb4.tgz
NetBSD 9.0aarch64libtecla-1.6.1nb4.tgz
NetBSD 9.0aarch64libtecla-1.6.1nb4.tgz
NetBSD 9.0alphalibtecla-1.6.1nb4.tgz
NetBSD 9.0alphalibtecla-1.6.1nb4.tgz
NetBSD 9.0alphalibtecla-1.6.1nb4.tgz
NetBSD 9.0earmlibtecla-1.6.1nb4.tgz
NetBSD 9.0earmlibtecla-1.6.1nb4.tgz
NetBSD 9.0earmlibtecla-1.6.1nb4.tgz
NetBSD 9.0earmv6hflibtecla-1.6.1nb4.tgz
NetBSD 9.0earmv6hflibtecla-1.6.1nb4.tgz
NetBSD 9.0earmv6hflibtecla-1.6.1nb4.tgz
NetBSD 9.0earmv6hflibtecla-1.6.1nb4.tgz
NetBSD 9.0earmv7hflibtecla-1.6.1nb4.tgz
NetBSD 9.0earmv7hflibtecla-1.6.1nb4.tgz
NetBSD 9.0earmv7hflibtecla-1.6.1nb4.tgz
NetBSD 9.0earmv7hflibtecla-1.6.1nb4.tgz
NetBSD 9.0i386libtecla-1.6.1nb4.tgz
NetBSD 9.0i386libtecla-1.6.1nb4.tgz
NetBSD 9.0i386libtecla-1.6.1nb4.tgz
NetBSD 9.0mips64eblibtecla-1.6.1nb4.tgz
NetBSD 9.0mips64eblibtecla-1.6.1nb4.tgz
NetBSD 9.0mips64eblibtecla-1.6.1nb4.tgz
NetBSD 9.0mipsellibtecla-1.6.1nb4.tgz
NetBSD 9.0mipsellibtecla-1.6.1nb4.tgz
NetBSD 9.0powerpclibtecla-1.6.1nb4.tgz
NetBSD 9.0powerpclibtecla-1.6.1nb4.tgz
NetBSD 9.0sparc64libtecla-1.6.1nb4.tgz
NetBSD 9.0sparc64libtecla-1.6.1nb4.tgz
NetBSD 9.0sparc64libtecla-1.6.1nb4.tgz
NetBSD 9.0sparc64libtecla-1.6.1nb4.tgz
NetBSD 9.0sparclibtecla-1.6.1nb4.tgz
NetBSD 9.0sparclibtecla-1.6.1nb4.tgz
NetBSD 9.0sparclibtecla-1.6.1nb4.tgz
NetBSD 9.0vaxlibtecla-1.6.1nb4.tgz
NetBSD 9.0vaxlibtecla-1.6.1nb4.tgz
NetBSD 9.0x86_64libtecla-1.6.1nb4.tgz
NetBSD 9.0x86_64libtecla-1.6.1nb4.tgz
NetBSD 9.0x86_64libtecla-1.6.1nb4.tgz
NetBSD 9.0x86_64libtecla-1.6.1nb4.tgz
NetBSD 9.0x86_64libtecla-1.6.1nb4.tgz
NetBSD 9.0x86_64libtecla-1.6.1nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.