devel/linenoise - The NetBSD Packages Collection

Small self-contained alternative to readline and libedit

A minimal, zero-config, BSD licensed, readline replacement.

Noteworthy features:
 - Single and multi line editing mode with the usual key bindings implemented.
 - History handling.
 - Completion.
 - Hints (suggestions at the right of the prompt as you type).
 - About 1,100 lines of BSD license source code.
 - Only uses a subset of VT100 escapes (ANSI.SYS compatible).

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflinenoise-1.0.tgz
NetBSD 8.0earmv7hflinenoise-1.0.tgz
NetBSD 8.0earmv7hflinenoise-1.0.tgz
NetBSD 8.0i386linenoise-1.0.tgz
NetBSD 8.0i386linenoise-1.0.tgz
NetBSD 8.0i386linenoise-1.0.tgz
NetBSD 8.0powerpclinenoise-1.0.tgz
NetBSD 8.0powerpclinenoise-1.0.tgz
NetBSD 8.0powerpclinenoise-1.0.tgz
NetBSD 8.0x86_64linenoise-1.0.tgz
NetBSD 8.0x86_64linenoise-1.0.tgz
NetBSD 9.0aarch64linenoise-1.0.tgz
NetBSD 9.0aarch64linenoise-1.0.tgz
NetBSD 9.0aarch64linenoise-1.0.tgz
NetBSD 9.0alphalinenoise-1.0.tgz
NetBSD 9.0alphalinenoise-1.0.tgz
NetBSD 9.0alphalinenoise-1.0.tgz
NetBSD 9.0earmlinenoise-1.0.tgz
NetBSD 9.0earmv6hflinenoise-1.0.tgz
NetBSD 9.0earmv6hflinenoise-1.0.tgz
NetBSD 9.0earmv6hflinenoise-1.0.tgz
NetBSD 9.0earmv6hflinenoise-1.0.tgz
NetBSD 9.0earmv7hflinenoise-1.0.tgz
NetBSD 9.0earmv7hflinenoise-1.0.tgz
NetBSD 9.0earmv7hflinenoise-1.0.tgz
NetBSD 9.0earmv7hflinenoise-1.0.tgz
NetBSD 9.0i386linenoise-1.0.tgz
NetBSD 9.0i386linenoise-1.0.tgz
NetBSD 9.0i386linenoise-1.0.tgz
NetBSD 9.0mips64eblinenoise-1.0.tgz
NetBSD 9.0mips64eblinenoise-1.0.tgz
NetBSD 9.0mips64eblinenoise-1.0.tgz
NetBSD 9.0powerpclinenoise-1.0.tgz
NetBSD 9.0powerpclinenoise-1.0.tgz
NetBSD 9.0sparc64linenoise-1.0.tgz
NetBSD 9.0sparc64linenoise-1.0.tgz
NetBSD 9.0sparc64linenoise-1.0.tgz
NetBSD 9.0sparc64linenoise-1.0.tgz
NetBSD 9.0sparclinenoise-1.0.tgz
NetBSD 9.0sparclinenoise-1.0.tgz
NetBSD 9.0sparclinenoise-1.0.tgz
NetBSD 9.0x86_64linenoise-1.0.tgz
NetBSD 9.0x86_64linenoise-1.0.tgz
NetBSD 9.0x86_64linenoise-1.0.tgz
NetBSD 9.0x86_64linenoise-1.0.tgz
NetBSD 9.0x86_64linenoise-1.0.tgz
NetBSD 9.0x86_64linenoise-1.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.