devel/lwp - The NetBSD Packages Collection

Light Weight Process style threads

This package implements LWP (light weight process) style threads.
The interface is simple, and the co-operative model used incurs
minimal run-time overhead on packages that utilize the library.

The original design and implementation of LWP was done by Larry Raper.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflwp-2.8.tgz
NetBSD 8.0earmv7hflwp-2.8.tgz
NetBSD 8.0earmv7hflwp-2.8.tgz
NetBSD 8.0i386lwp-2.8.tgz
NetBSD 8.0i386lwp-2.8.tgz
NetBSD 8.0i386lwp-2.8.tgz
NetBSD 8.0powerpclwp-2.8.tgz
NetBSD 8.0powerpclwp-2.8.tgz
NetBSD 8.0powerpclwp-2.8.tgz
NetBSD 8.0x86_64lwp-2.8.tgz
NetBSD 8.0x86_64lwp-2.8.tgz
NetBSD 9.0aarch64lwp-2.8.tgz
NetBSD 9.0aarch64lwp-2.8.tgz
NetBSD 9.0aarch64lwp-2.8.tgz
NetBSD 9.0alphalwp-2.8.tgz
NetBSD 9.0alphalwp-2.8.tgz
NetBSD 9.0alphalwp-2.8.tgz
NetBSD 9.0earmlwp-2.8.tgz
NetBSD 9.0earmlwp-2.8.tgz
NetBSD 9.0earmlwp-2.8.tgz
NetBSD 9.0earmv6hflwp-2.8.tgz
NetBSD 9.0earmv6hflwp-2.8.tgz
NetBSD 9.0earmv6hflwp-2.8.tgz
NetBSD 9.0earmv6hflwp-2.8.tgz
NetBSD 9.0earmv7hflwp-2.8.tgz
NetBSD 9.0earmv7hflwp-2.8.tgz
NetBSD 9.0earmv7hflwp-2.8.tgz
NetBSD 9.0earmv7hflwp-2.8.tgz
NetBSD 9.0i386lwp-2.8.tgz
NetBSD 9.0i386lwp-2.8.tgz
NetBSD 9.0i386lwp-2.8.tgz
NetBSD 9.0mips64eblwp-2.8.tgz
NetBSD 9.0mips64eblwp-2.8.tgz
NetBSD 9.0mips64eblwp-2.8.tgz
NetBSD 9.0mipsellwp-2.8.tgz
NetBSD 9.0mipsellwp-2.8.tgz
NetBSD 9.0powerpclwp-2.8.tgz
NetBSD 9.0powerpclwp-2.8.tgz
NetBSD 9.0sh3ellwp-2.8.tgz
NetBSD 9.0sh3ellwp-2.8.tgz
NetBSD 9.0sparc64lwp-2.8.tgz
NetBSD 9.0sparc64lwp-2.8.tgz
NetBSD 9.0sparc64lwp-2.8.tgz
NetBSD 9.0sparc64lwp-2.8.tgz
NetBSD 9.0sparclwp-2.8.tgz
NetBSD 9.0sparclwp-2.8.tgz
NetBSD 9.0sparclwp-2.8.tgz
NetBSD 9.0vaxlwp-2.8.tgz
NetBSD 9.0vaxlwp-2.8.tgz
NetBSD 9.0x86_64lwp-2.8.tgz
NetBSD 9.0x86_64lwp-2.8.tgz
NetBSD 9.0x86_64lwp-2.8.tgz
NetBSD 9.0x86_64lwp-2.8.tgz
NetBSD 9.0x86_64lwp-2.8.tgz
NetBSD 9.0x86_64lwp-2.8.tgz
NetBSD 9.0x86_64lwp-2.8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.