devel/m17n-lib - The NetBSD Packages Collection

Multilingualization library

The m17n library is a multilingual text processing library for the C language.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

fonts/fontconfig fonts/fontconfig graphics/freetype2 graphics/freetype2 graphics/gd graphics/libotf graphics/libotf fonts/Xft2 fonts/Xft2 converters/fribidi misc/m17n-db textproc/libxml2 fonts/fontconfig graphics/gd graphics/libotf fonts/Xft2 textproc/libxml2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfm17n-lib-1.8.0nb4.tgz
NetBSD 8.0earmv7hfm17n-lib-1.8.0nb3.tgz
NetBSD 8.0earmv7hfm17n-lib-1.8.0nb4.tgz
NetBSD 8.0i386m17n-lib-1.8.0nb3.tgz
NetBSD 8.0i386m17n-lib-1.8.0nb4.tgz
NetBSD 8.0i386m17n-lib-1.8.0nb4.tgz
NetBSD 8.0powerpcm17n-lib-1.8.0nb3.tgz
NetBSD 8.0powerpcm17n-lib-1.8.0nb4.tgz
NetBSD 8.0powerpcm17n-lib-1.8.0nb4.tgz
NetBSD 8.0powerpcm17n-lib-1.8.0nb4.tgz
NetBSD 8.0x86_64m17n-lib-1.8.0nb4.tgz
NetBSD 8.0x86_64m17n-lib-1.8.0nb3.tgz
NetBSD 8.0x86_64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0aarch64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0aarch64m17n-lib-1.8.0nb3.tgz
NetBSD 9.0aarch64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0alpham17n-lib-1.8.0nb4.tgz
NetBSD 9.0alpham17n-lib-1.8.0nb3.tgz
NetBSD 9.0alpham17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmm17n-lib-1.8.0nb3.tgz
NetBSD 9.0earmm17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmm17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmv6hfm17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmv6hfm17n-lib-1.8.0nb3.tgz
NetBSD 9.0earmv6hfm17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmv6hfm17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmv7hfm17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmv7hfm17n-lib-1.8.0nb3.tgz
NetBSD 9.0earmv7hfm17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmv7hfm17n-lib-1.8.0nb4.tgz
NetBSD 9.0earmv7hfm17n-lib-1.8.0nb4.tgz
NetBSD 9.0i386m17n-lib-1.8.0nb3.tgz
NetBSD 9.0i386m17n-lib-1.8.0nb4.tgz
NetBSD 9.0i386m17n-lib-1.8.0nb4.tgz
NetBSD 9.0m68km17n-lib-1.8.0nb4.tgz
NetBSD 9.0m68km17n-lib-1.8.0nb3.tgz
NetBSD 9.0m68km17n-lib-1.8.0nb4.tgz
NetBSD 9.0mips64ebm17n-lib-1.8.0nb4.tgz
NetBSD 9.0mips64ebm17n-lib-1.8.0nb3.tgz
NetBSD 9.0mips64ebm17n-lib-1.8.0nb4.tgz
NetBSD 9.0mipselm17n-lib-1.8.0nb4.tgz
NetBSD 9.0mipselm17n-lib-1.8.0nb4.tgz
NetBSD 9.0powerpcm17n-lib-1.8.0nb4.tgz
NetBSD 9.0powerpcm17n-lib-1.8.0nb3.tgz
NetBSD 9.0powerpcm17n-lib-1.8.0nb4.tgz
NetBSD 9.0powerpcm17n-lib-1.8.0nb4.tgz
NetBSD 9.0sh3elm17n-lib-1.8.0nb4.tgz
NetBSD 9.0sh3elm17n-lib-1.8.0nb4.tgz
NetBSD 9.0sparc64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0sparc64m17n-lib-1.8.0nb2.tgz
NetBSD 9.0sparc64m17n-lib-1.8.0nb3.tgz
NetBSD 9.0sparc64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0sparcm17n-lib-1.8.0nb4.tgz
NetBSD 9.0sparcm17n-lib-1.8.0nb3.tgz
NetBSD 9.0sparcm17n-lib-1.8.0nb4.tgz
NetBSD 9.0vaxm17n-lib-1.8.0nb4.tgz
NetBSD 9.0vaxm17n-lib-1.8.0nb4.tgz
NetBSD 9.0x86_64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0x86_64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0x86_64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0x86_64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0x86_64m17n-lib-1.8.0nb3.tgz
NetBSD 9.0x86_64m17n-lib-1.8.0nb4.tgz
NetBSD 9.0x86_64m17n-lib-1.8.0nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

anthy
Use Anthy as Japanese conversion program.
ispell
Add spell checking support using ispell.
libthai
Use libthai for Thai word segmentation.
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.