devel/mad-flute - The NetBSD Packages Collection

Reliable Multicast Layering

MAD project implemented two protocols designed for reliable content
delivery.  File Delivery over Unidirectional Transport (FLUTE) is a
protocol for the unidirectional delivery of files over the Internet,
which is particularly suited to multicast networks.  FLUTE builds on
Asyncronous Layered Coding (ALC), the base protocol designed for
massively scalable multicast distribution.  Asynchronous Layered
Coding combines the Layered Coding Transport (LCT) building block, a
multiple rate congestion control building block and the Forward Error
Correction (FEC) building block to provide congestion controlled
reliable asynchronous delivery of content to an unlimited number of
concurrent receivers from a single sender.

MAD-ALCLIB library is an implementation of the ALC/LCT protocol, along
with the RLC congestion control protocol and Compact No-Code, Simple
XOR and Reed-Solomon FEC schemes.  Session Description Protocol (SDP)
can be used to describe FLUTE sessions.  MAD-SDPLIB library is an
implementation of "SDP Descriptors for FLUTE" Internet-Draft.
MAD-FLUTELIB is an implementation of the FLUTE protocol, and it builds
on MAD-ALCLIB and MAD-SDPLIB libraries.  MAD-FLUTE is a multicast file
transfer tool build on the above mentioned libraries.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

www/curl www/curl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmad-flute-1.7nb20.tgz
NetBSD 8.0earmv7hfmad-flute-1.7nb20.tgz
NetBSD 8.0earmv7hfmad-flute-1.7nb20.tgz
NetBSD 8.0i386mad-flute-1.7nb20.tgz
NetBSD 8.0i386mad-flute-1.7nb20.tgz
NetBSD 8.0i386mad-flute-1.7nb20.tgz
NetBSD 8.0powerpcmad-flute-1.7nb20.tgz
NetBSD 8.0powerpcmad-flute-1.7nb20.tgz
NetBSD 8.0powerpcmad-flute-1.7nb20.tgz
NetBSD 8.0x86_64mad-flute-1.7nb20.tgz
NetBSD 8.0x86_64mad-flute-1.7nb20.tgz
NetBSD 9.0aarch64mad-flute-1.7nb20.tgz
NetBSD 9.0aarch64mad-flute-1.7nb20.tgz
NetBSD 9.0aarch64mad-flute-1.7nb20.tgz
NetBSD 9.0alphamad-flute-1.7nb20.tgz
NetBSD 9.0alphamad-flute-1.7nb20.tgz
NetBSD 9.0alphamad-flute-1.7nb20.tgz
NetBSD 9.0earmmad-flute-1.7nb20.tgz
NetBSD 9.0earmv6hfmad-flute-1.7nb20.tgz
NetBSD 9.0earmv6hfmad-flute-1.7nb20.tgz
NetBSD 9.0earmv6hfmad-flute-1.7nb20.tgz
NetBSD 9.0earmv6hfmad-flute-1.7nb20.tgz
NetBSD 9.0earmv7hfmad-flute-1.7nb20.tgz
NetBSD 9.0earmv7hfmad-flute-1.7nb20.tgz
NetBSD 9.0earmv7hfmad-flute-1.7nb20.tgz
NetBSD 9.0earmv7hfmad-flute-1.7nb20.tgz
NetBSD 9.0i386mad-flute-1.7nb20.tgz
NetBSD 9.0i386mad-flute-1.7nb20.tgz
NetBSD 9.0i386mad-flute-1.7nb20.tgz
NetBSD 9.0mips64ebmad-flute-1.7nb20.tgz
NetBSD 9.0mips64ebmad-flute-1.7nb20.tgz
NetBSD 9.0mips64ebmad-flute-1.7nb20.tgz
NetBSD 9.0powerpcmad-flute-1.7nb20.tgz
NetBSD 9.0powerpcmad-flute-1.7nb20.tgz
NetBSD 9.0sparc64mad-flute-1.7nb20.tgz
NetBSD 9.0sparc64mad-flute-1.7nb20.tgz
NetBSD 9.0sparc64mad-flute-1.7nb20.tgz
NetBSD 9.0sparc64mad-flute-1.7nb20.tgz
NetBSD 9.0sparcmad-flute-1.7nb20.tgz
NetBSD 9.0sparcmad-flute-1.7nb20.tgz
NetBSD 9.0sparcmad-flute-1.7nb20.tgz
NetBSD 9.0x86_64mad-flute-1.7nb20.tgz
NetBSD 9.0x86_64mad-flute-1.7nb20.tgz
NetBSD 9.0x86_64mad-flute-1.7nb20.tgz
NetBSD 9.0x86_64mad-flute-1.7nb20.tgz
NetBSD 9.0x86_64mad-flute-1.7nb20.tgz
NetBSD 9.0x86_64mad-flute-1.7nb20.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.