devel/nqc - The NetBSD Packages Collection

Development system for the Lego Mindstorms RCX embedded computer

Not Quite C is a simple language with a C like syntax that can be used
to program Lego's RCX programmable brick (from the Mindstorms set). If
you are just getting started with programming, then graphical
environments such as the Mindstorms RIS software or Robolab are
probably better choices. If, however, you're a C programmer and prefer
typing a few lines to drag and drop icon programming, then NQC may be
perfect for you.

NQC is free software released under the Mozilla Public License (MPL).

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfnqc-2.3.1.tgz
NetBSD 8.0earmv7hfnqc-2.3.1.tgz
NetBSD 8.0earmv7hfnqc-2.3.1.tgz
NetBSD 8.0i386nqc-2.3.1.tgz
NetBSD 8.0i386nqc-2.3.1.tgz
NetBSD 8.0i386nqc-2.3.1.tgz
NetBSD 8.0powerpcnqc-2.3.1.tgz
NetBSD 8.0powerpcnqc-2.3.1.tgz
NetBSD 8.0powerpcnqc-2.3.1.tgz
NetBSD 8.0x86_64nqc-2.3.1.tgz
NetBSD 8.0x86_64nqc-2.3.1.tgz
NetBSD 9.0aarch64nqc-2.3.1.tgz
NetBSD 9.0aarch64nqc-2.3.1.tgz
NetBSD 9.0aarch64nqc-2.3.1.tgz
NetBSD 9.0alphanqc-2.3.1.tgz
NetBSD 9.0alphanqc-2.3.1.tgz
NetBSD 9.0alphanqc-2.3.1.tgz
NetBSD 9.0earmnqc-2.3.1.tgz
NetBSD 9.0earmv6hfnqc-2.3.1.tgz
NetBSD 9.0earmv6hfnqc-2.3.1.tgz
NetBSD 9.0earmv6hfnqc-2.3.1.tgz
NetBSD 9.0earmv6hfnqc-2.3.1.tgz
NetBSD 9.0earmv7hfnqc-2.3.1.tgz
NetBSD 9.0earmv7hfnqc-2.3.1.tgz
NetBSD 9.0earmv7hfnqc-2.3.1.tgz
NetBSD 9.0earmv7hfnqc-2.3.1.tgz
NetBSD 9.0i386nqc-2.3.1.tgz
NetBSD 9.0i386nqc-2.3.1.tgz
NetBSD 9.0mips64ebnqc-2.3.1.tgz
NetBSD 9.0mips64ebnqc-2.3.1.tgz
NetBSD 9.0mips64ebnqc-2.3.1.tgz
NetBSD 9.0powerpcnqc-2.3.1.tgz
NetBSD 9.0powerpcnqc-2.3.1.tgz
NetBSD 9.0sparc64nqc-2.3.1.tgz
NetBSD 9.0sparc64nqc-2.3.1.tgz
NetBSD 9.0sparc64nqc-2.3.1.tgz
NetBSD 9.0sparc64nqc-2.3.1.tgz
NetBSD 9.0sparcnqc-2.3.1.tgz
NetBSD 9.0sparcnqc-2.3.1.tgz
NetBSD 9.0sparcnqc-2.3.1.tgz
NetBSD 9.0x86_64nqc-2.3.1.tgz
NetBSD 9.0x86_64nqc-2.3.1.tgz
NetBSD 9.0x86_64nqc-2.3.1.tgz
NetBSD 9.0x86_64nqc-2.3.1.tgz
NetBSD 9.0x86_64nqc-2.3.1.tgz
NetBSD 9.0x86_64nqc-2.3.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.