devel/ocaml-lru - The NetBSD Packages Collection

Scalable LRU caches for OCaml

ocaml-lru provides LRU caches for OCaml. These are size-bounded finite maps that
remove the least-recently-used (LRU) bindings to maintain their size constraint.

Build dependencies

devel/ocamlbuild misc/ocaml-opaline pkgtools/cwrappers devel/ocamlbuild misc/ocaml-opaline

Runtime dependencies

devel/ocaml-psq misc/ocaml-topkg devel/ocaml-findlib lang/ocaml misc/ocaml-topkg devel/ocaml-findlib

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-lru-0.2.0.tgz
NetBSD 8.0i386ocaml-lru-0.2.0.tgz
NetBSD 8.0i386ocaml-lru-0.2.0nb1.tgz
NetBSD 8.0powerpcocaml-lru-0.2.0.tgz
NetBSD 8.0powerpcocaml-lru-0.2.0.tgz
NetBSD 8.0x86_64ocaml-lru-0.2.0nb1.tgz
NetBSD 8.0x86_64ocaml-lru-0.2.0.tgz
NetBSD 8.0x86_64ocaml-lru-0.2.0.tgz
NetBSD 9.0aarch64ocaml-lru-0.2.0nb1.tgz
NetBSD 9.0aarch64ocaml-lru-0.2.0.tgz
NetBSD 9.0aarch64ocaml-lru-0.2.0.tgz
NetBSD 9.0earmv6hfocaml-lru-0.2.0nb1.tgz
NetBSD 9.0earmv6hfocaml-lru-0.2.0.tgz
NetBSD 9.0earmv6hfocaml-lru-0.2.0.tgz
NetBSD 9.0earmv7hfocaml-lru-0.2.0nb1.tgz
NetBSD 9.0earmv7hfocaml-lru-0.2.0.tgz
NetBSD 9.0earmv7hfocaml-lru-0.2.0.tgz
NetBSD 9.0earmv7hfocaml-lru-0.2.0nb1.tgz
NetBSD 9.0i386ocaml-lru-0.2.0.tgz
NetBSD 9.0i386ocaml-lru-0.2.0.tgz
NetBSD 9.0i386ocaml-lru-0.2.0nb1.tgz
NetBSD 9.0powerpcocaml-lru-0.2.0.tgz
NetBSD 9.0powerpcocaml-lru-0.2.0nb1.tgz
NetBSD 9.0x86_64ocaml-lru-0.2.0.tgz
NetBSD 9.0x86_64ocaml-lru-0.2.0.tgz
NetBSD 9.0x86_64ocaml-lru-0.2.0.tgz
NetBSD 9.0x86_64ocaml-lru-0.2.0nb1.tgz
NetBSD 9.0x86_64ocaml-lru-0.2.0.tgz
NetBSD 9.0x86_64ocaml-lru-0.2.0.tgz
NetBSD 9.0x86_64ocaml-lru-0.2.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.