devel/ocaml-ocplib-endian - The NetBSD Packages Collection

Optimised functions to read and write int16/32/64

Optimised functions to read and write int16/32/64 from strings, bytes and
bigarrays, based on primitives added in version 4.01.

The library implements three modules:

* EndianString works directly on strings, and provides submodules BigEndian and
  LittleEndian, with their unsafe counter-parts;
* EndianBytes works directly on bytes, and provides submodules BigEndian and
  LittleEndian, with their unsafe counter-parts;
* EndianBigstring works on bigstrings (Bigarrays of chars), and provides
  submodules BigEndian and LittleEndian, with their unsafe counter-parts.

Build dependencies

devel/ocamlbuild pkgtools/cwrappers devel/ocamlbuild

Runtime dependencies

devel/ocaml-findlib lang/ocaml devel/ocaml-cppo devel/ocaml-findlib devel/ocaml-cppo

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-ocplib-endian-1.0.tgz
NetBSD 8.0i386ocaml-ocplib-endian-1.0.tgz
NetBSD 8.0i386ocaml-ocplib-endian-1.0nb1.tgz
NetBSD 8.0powerpcocaml-ocplib-endian-1.0.tgz
NetBSD 8.0powerpcocaml-ocplib-endian-1.0.tgz
NetBSD 8.0x86_64ocaml-ocplib-endian-1.0.tgz
NetBSD 8.0x86_64ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0aarch64ocaml-ocplib-endian-1.0nb1.tgz
NetBSD 9.0aarch64ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0aarch64ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0earmv6hfocaml-ocplib-endian-1.0nb1.tgz
NetBSD 9.0earmv6hfocaml-ocplib-endian-1.0.tgz
NetBSD 9.0earmv6hfocaml-ocplib-endian-1.0.tgz
NetBSD 9.0earmv7hfocaml-ocplib-endian-1.0nb1.tgz
NetBSD 9.0earmv7hfocaml-ocplib-endian-1.0.tgz
NetBSD 9.0earmv7hfocaml-ocplib-endian-1.0.tgz
NetBSD 9.0i386ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0i386ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0powerpcocaml-ocplib-endian-1.0.tgz
NetBSD 9.0x86_64ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0x86_64ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0x86_64ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0x86_64ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0x86_64ocaml-ocplib-endian-1.0.tgz
NetBSD 9.0x86_64ocaml-ocplib-endian-1.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.