devel/ocaml-ppx_optcomp - The NetBSD Packages Collection

Optional compilation for OCaml

ppx_optcomp stands for Optional Compilation. It is a tool used to handle
optional compilations of pieces of code depending of the word size, the version
of the compiler, ...

ppx_optcomp can be used a a standalone pre-processor, but is also integrated in
the ppx_driver.

Build dependencies

misc/ocaml-opaline pkgtools/cwrappers misc/ocaml-opaline

Runtime dependencies

devel/ocaml-dune devel/ocaml-findlib lang/ocaml devel/ocaml-base devel/ocaml-stdio devel/ocaml-ppxlib devel/ocaml-dune devel/ocaml-findlib devel/ocaml-base devel/ocaml-stdio devel/ocaml-ppxlib

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 8.0i386ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 8.0i386ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 8.0powerpcocaml-ppx_optcomp-0.13.0.tgz
NetBSD 8.0powerpcocaml-ppx_optcomp-0.13.0.tgz
NetBSD 8.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 8.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 8.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0aarch64ocaml-ppx_optcomp-0.13.0nb1.tgz
NetBSD 9.0aarch64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0aarch64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0aarch64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0earmv6hfocaml-ppx_optcomp-0.13.0nb1.tgz
NetBSD 9.0earmv6hfocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0earmv6hfocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0earmv7hfocaml-ppx_optcomp-0.13.0nb1.tgz
NetBSD 9.0earmv7hfocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0earmv7hfocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0i386ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0i386ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0i386ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0powerpcocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0x86_64ocaml-ppx_optcomp-0.13.0.tgz
NetBSD 9.0x86_64ocaml-ppx_optcomp-0.13.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.