devel/p5-Acme-PlayCode - The NetBSD Packages Collection

Perl5 module for code transforming to avoid typical typing mistakes

Acme::PlayCode provides some code transformations via plugins to convert
existing code into code with lesser risk of typing errors, e.g.
'if($a == 5)' -> 'if(5 == $a)' to avoid typo like 'if($a = 5)'.

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

devel/p5-List-MoreUtils devel/p5-Moose devel/p5-MooseX-Object-Pluggable devel/p5-PPI devel/p5-Path-Class lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0earmv7hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0earmv7hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0i386p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0i386p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0i386p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0powerpcp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0powerpcp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0powerpcp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0x86_64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 8.0x86_64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0aarch64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0aarch64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0aarch64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0alphap5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0alphap5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0alphap5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmv6hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmv6hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmv6hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmv6hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmv7hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmv7hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmv7hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0earmv7hfp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0i386p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0i386p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0mips64ebp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0mips64ebp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0mips64ebp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0powerpcp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0powerpcp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0sparc64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0sparc64p5-Acme-PlayCode-0.12nb10.tgz
NetBSD 9.0sparc64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0sparc64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0sparcp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0sparcp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0sparcp5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0x86_64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0x86_64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0x86_64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0x86_64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0x86_64p5-Acme-PlayCode-0.12nb11.tgz
NetBSD 9.0x86_64p5-Acme-PlayCode-0.12nb11.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.