devel/p5-Async-Interrupt - The NetBSD Packages Collection

Allow C/XS libraries to interrupt perl asynchronously

This module implements a single feature only of interest to advanced perl
modules, namely asynchronous interruptions (think "UNIX signals", which are
very similar).

Sometimes, modules wish to run code asynchronously (in another thread, or
from a signal handler), and then signal the perl interpreter on certain
events. One common way is to write some data to a pipe and use an event
handling toolkit to watch for I/O events. Another way is to send a signal.
Those methods are slow, and in the case of a pipe, also not asynchronous -
it won't interrupt a running perl interpreter.

This module implements asynchronous notifications that enable you to signal
running perl code from another thread, asynchronously, and sometimes even
without using a single syscall.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-common-sense devel/p5-Canary-Stability lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0earmv7hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0earmv7hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0i386p5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0i386p5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0i386p5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0powerpcp5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0powerpcp5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0powerpcp5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 8.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0aarch64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0aarch64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0alphap5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0alphap5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0alphap5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmv6hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmv6hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmv6hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmv7hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmv7hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0earmv7hfp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0i386p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0i386p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0i386p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0m68kp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0mips64ebp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0mips64ebp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0mips64ebp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0mipselp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0mipselp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0powerpcp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0powerpcp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sh3elp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sh3elp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sh3elp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sparc64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sparc64p5-Async-Interrupt-1.26.tgz
NetBSD 9.0sparc64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sparc64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sparcp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sparcp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0sparcp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0vaxp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0vaxp5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0x86_64p5-Async-Interrupt-1.26nb1.tgz
NetBSD 9.0x86_64p5-Async-Interrupt-1.26nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.