devel/p5-Class-Container - The NetBSD Packages Collection

Glues object frameworks together transparently

This class facilitates building frameworks of several classes that
inter-operate. It was first designed and built for "HTML::Mason", in which
the Compiler, Lexer, Interpreter, Resolver, Component, Buffer, and several
other objects must create each other transparently, passing the appropriate
parameters to the right class, possibly substituting other subclasses for
any of these objects.

The main features of "Class::Container" are:

 *   Explicit declaration of containment relationships (aggregation, factory
     creation, etc.)

 *   Declaration of constructor parameters accepted by each member in a class
     framework

 *   Transparent passing of constructor parameters to the class that needs
     them

 *   Ability to create one (automatic) or many (manual) contained objects
     automatically and transparently

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

devel/p5-Params-Validate lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Class-Container-0.13nb3.tgz
NetBSD 8.0earmv7hfp5-Class-Container-0.13nb3.tgz
NetBSD 8.0earmv7hfp5-Class-Container-0.13nb3.tgz
NetBSD 8.0i386p5-Class-Container-0.13nb3.tgz
NetBSD 8.0i386p5-Class-Container-0.13nb3.tgz
NetBSD 8.0powerpcp5-Class-Container-0.13nb3.tgz
NetBSD 8.0powerpcp5-Class-Container-0.13nb3.tgz
NetBSD 8.0powerpcp5-Class-Container-0.13nb3.tgz
NetBSD 8.0x86_64p5-Class-Container-0.13nb3.tgz
NetBSD 8.0x86_64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0aarch64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0aarch64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0aarch64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0alphap5-Class-Container-0.13nb3.tgz
NetBSD 9.0alphap5-Class-Container-0.13nb3.tgz
NetBSD 9.0alphap5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmv6hfp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmv6hfp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmv6hfp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmv6hfp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmv7hfp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmv7hfp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmv7hfp5-Class-Container-0.13nb3.tgz
NetBSD 9.0earmv7hfp5-Class-Container-0.13nb3.tgz
NetBSD 9.0i386p5-Class-Container-0.13nb3.tgz
NetBSD 9.0i386p5-Class-Container-0.13nb3.tgz
NetBSD 9.0m68kp5-Class-Container-0.13nb3.tgz
NetBSD 9.0mips64ebp5-Class-Container-0.13nb3.tgz
NetBSD 9.0mips64ebp5-Class-Container-0.13nb3.tgz
NetBSD 9.0mips64ebp5-Class-Container-0.13nb3.tgz
NetBSD 9.0mipselp5-Class-Container-0.13nb3.tgz
NetBSD 9.0mipselp5-Class-Container-0.13nb3.tgz
NetBSD 9.0powerpcp5-Class-Container-0.13nb3.tgz
NetBSD 9.0powerpcp5-Class-Container-0.13nb3.tgz
NetBSD 9.0sh3elp5-Class-Container-0.13nb3.tgz
NetBSD 9.0sh3elp5-Class-Container-0.13nb3.tgz
NetBSD 9.0sh3elp5-Class-Container-0.13nb3.tgz
NetBSD 9.0sparc64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0sparc64p5-Class-Container-0.13nb2.tgz
NetBSD 9.0sparc64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0sparc64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0sparcp5-Class-Container-0.13nb3.tgz
NetBSD 9.0sparcp5-Class-Container-0.13nb3.tgz
NetBSD 9.0sparcp5-Class-Container-0.13nb3.tgz
NetBSD 9.0vaxp5-Class-Container-0.13nb3.tgz
NetBSD 9.0vaxp5-Class-Container-0.13nb3.tgz
NetBSD 9.0x86_64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0x86_64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0x86_64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0x86_64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0x86_64p5-Class-Container-0.13nb3.tgz
NetBSD 9.0x86_64p5-Class-Container-0.13nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.