devel/p5-Data-Validate-IP - The NetBSD Packages Collection

IPv4 and IPv6 validation methods

This module provides a number IP address validation subs that both validate
and untaint their input. This includes both basic validation (is_ipv4() and
is_ipv6()) and special cases like checking whether an address belongs to a
specific network or whether an address is public or private (reserved).

Build dependencies

pkgtools/cwrappers

Runtime dependencies

net/p5-NetAddr-IP lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0earmv7hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0earmv7hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0i386p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0i386p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0i386p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0powerpcp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0powerpcp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0powerpcp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0x86_64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 8.0x86_64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0aarch64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0aarch64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0aarch64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0alphap5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0alphap5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0alphap5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmv6hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmv6hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmv6hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmv6hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmv7hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmv7hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmv7hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0earmv7hfp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0i386p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0i386p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0mips64ebp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0mips64ebp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0mips64ebp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0mipselp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0mipselp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0powerpcp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0powerpcp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0sh3elp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0sh3elp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0sparc64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0sparc64p5-Data-Validate-IP-0.27nb1.tgz
NetBSD 9.0sparc64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0sparc64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0sparcp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0sparcp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0sparcp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0vaxp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0vaxp5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0x86_64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0x86_64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0x86_64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0x86_64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0x86_64p5-Data-Validate-IP-0.27nb2.tgz
NetBSD 9.0x86_64p5-Data-Validate-IP-0.27nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.