devel/p5-Devel-Hide - The NetBSD Packages Collection

Meatier versions of caller

Given a list of Perl modules/filenames, this module makes require and use
statements fail (no matter the specified files/modules are installed or
not).

They die with a message like:

    Can't locate Module/ToHide.pm (hidden)

The intent of this module is to allow Perl developers to test for
alternative behavior when some modules are not available. In a Perl
installation, where many modules are already installed, there is a
chance to screw things up because you take for granted things that
may not be there in other machines.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 8.0earmv7hfp5-Devel-Hide-0.0013.tgz
NetBSD 8.0earmv7hfp5-Devel-Hide-0.0013.tgz
NetBSD 8.0earmv7hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 8.0i386p5-Devel-Hide-0.0013.tgz
NetBSD 8.0i386p5-Devel-Hide-0.0013nb1.tgz
NetBSD 8.0i386p5-Devel-Hide-0.0013nb1.tgz
NetBSD 8.0powerpcp5-Devel-Hide-0.0013nb1.tgz
NetBSD 8.0powerpcp5-Devel-Hide-0.0013nb1.tgz
NetBSD 8.0powerpcp5-Devel-Hide-0.0013nb1.tgz
NetBSD 8.0x86_64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 8.0x86_64p5-Devel-Hide-0.0013.tgz
NetBSD 8.0x86_64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0aarch64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0aarch64p5-Devel-Hide-0.0013.tgz
NetBSD 9.0aarch64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0aarch64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0alphap5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0alphap5-Devel-Hide-0.0013.tgz
NetBSD 9.0alphap5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0alphap5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmp5-Devel-Hide-0.0013.tgz
NetBSD 9.0earmp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmv6hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmv6hfp5-Devel-Hide-0.0013.tgz
NetBSD 9.0earmv6hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmv6hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmv6hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmv7hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmv7hfp5-Devel-Hide-0.0013.tgz
NetBSD 9.0earmv7hfp5-Devel-Hide-0.0013.tgz
NetBSD 9.0earmv7hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmv7hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0earmv7hfp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0i386p5-Devel-Hide-0.0013.tgz
NetBSD 9.0i386p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0i386p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0m68kp5-Devel-Hide-0.0013.tgz
NetBSD 9.0mips64ebp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0mips64ebp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0mips64ebp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0mipselp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0mipselp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0powerpcp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0powerpcp5-Devel-Hide-0.0013.tgz
NetBSD 9.0powerpcp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0sh3elp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0sh3elp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0sparc64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0sparc64p5-Devel-Hide-0.0013.tgz
NetBSD 9.0sparc64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0sparc64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0sparcp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0sparcp5-Devel-Hide-0.0013.tgz
NetBSD 9.0sparcp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0sparcp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0vaxp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0vaxp5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0x86_64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0x86_64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0x86_64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0x86_64p5-Devel-Hide-0.0013.tgz
NetBSD 9.0x86_64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0x86_64p5-Devel-Hide-0.0013nb1.tgz
NetBSD 9.0x86_64p5-Devel-Hide-0.0013nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.