devel/p5-EV - The NetBSD Packages Collection

Perl interface to libev, a high performance full-featured event loop

This module provides an interface to libev
(http://software.schmorp.de/pkg/libev.html). While the documentation is
comprehensive, one might also consult the documentation of libev itself
(http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod or perldoc EV::libev)
for more subtle details on watcher semantics or some discussion on the
available backends, or how to force a specific backend with LIBEV_FLAGS,
or just about in any case because it has much more detailed information.

This module is very fast and scalable. It is actually so fast that you can
use it through the AnyEvent module, stay portable to other event loops (if
you don't rely on any watcher types not available through it) and still be
faster than with any other event loop currently supported in Perl.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-common-sense devel/p5-Canary-Stability lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-EV-4.33nb1.tgz
NetBSD 8.0earmv7hfp5-EV-4.33nb1.tgz
NetBSD 8.0earmv7hfp5-EV-4.33nb1.tgz
NetBSD 8.0i386p5-EV-4.33nb1.tgz
NetBSD 8.0i386p5-EV-4.33nb1.tgz
NetBSD 8.0i386p5-EV-4.33nb1.tgz
NetBSD 8.0powerpcp5-EV-4.33nb1.tgz
NetBSD 8.0powerpcp5-EV-4.33nb1.tgz
NetBSD 8.0powerpcp5-EV-4.33nb1.tgz
NetBSD 8.0x86_64p5-EV-4.33nb1.tgz
NetBSD 8.0x86_64p5-EV-4.33nb1.tgz
NetBSD 9.0aarch64p5-EV-4.33nb1.tgz
NetBSD 9.0aarch64p5-EV-4.33nb1.tgz
NetBSD 9.0aarch64p5-EV-4.33nb1.tgz
NetBSD 9.0alphap5-EV-4.33nb1.tgz
NetBSD 9.0alphap5-EV-4.33nb1.tgz
NetBSD 9.0alphap5-EV-4.33nb1.tgz
NetBSD 9.0earmp5-EV-4.33nb1.tgz
NetBSD 9.0earmp5-EV-4.33nb1.tgz
NetBSD 9.0earmp5-EV-4.33nb1.tgz
NetBSD 9.0earmv6hfp5-EV-4.33nb1.tgz
NetBSD 9.0earmv6hfp5-EV-4.33nb1.tgz
NetBSD 9.0earmv6hfp5-EV-4.33nb1.tgz
NetBSD 9.0earmv6hfp5-EV-4.33nb1.tgz
NetBSD 9.0earmv7hfp5-EV-4.33nb1.tgz
NetBSD 9.0earmv7hfp5-EV-4.33nb1.tgz
NetBSD 9.0earmv7hfp5-EV-4.33nb1.tgz
NetBSD 9.0earmv7hfp5-EV-4.33nb1.tgz
NetBSD 9.0i386p5-EV-4.33nb1.tgz
NetBSD 9.0i386p5-EV-4.33nb1.tgz
NetBSD 9.0m68kp5-EV-4.33nb1.tgz
NetBSD 9.0mips64ebp5-EV-4.33nb1.tgz
NetBSD 9.0mips64ebp5-EV-4.33nb1.tgz
NetBSD 9.0mips64ebp5-EV-4.33nb1.tgz
NetBSD 9.0mipselp5-EV-4.33nb1.tgz
NetBSD 9.0mipselp5-EV-4.33nb1.tgz
NetBSD 9.0powerpcp5-EV-4.33nb1.tgz
NetBSD 9.0powerpcp5-EV-4.33nb1.tgz
NetBSD 9.0sh3elp5-EV-4.33nb1.tgz
NetBSD 9.0sh3elp5-EV-4.33nb1.tgz
NetBSD 9.0sh3elp5-EV-4.33nb1.tgz
NetBSD 9.0sparc64p5-EV-4.33nb1.tgz
NetBSD 9.0sparc64p5-EV-4.33.tgz
NetBSD 9.0sparc64p5-EV-4.33nb1.tgz
NetBSD 9.0sparc64p5-EV-4.33nb1.tgz
NetBSD 9.0vaxp5-EV-4.33nb1.tgz
NetBSD 9.0vaxp5-EV-4.33nb1.tgz
NetBSD 9.0x86_64p5-EV-4.33nb1.tgz
NetBSD 9.0x86_64p5-EV-4.33nb1.tgz
NetBSD 9.0x86_64p5-EV-4.33nb1.tgz
NetBSD 9.0x86_64p5-EV-4.33nb1.tgz
NetBSD 9.0x86_64p5-EV-4.33nb1.tgz
NetBSD 9.0x86_64p5-EV-4.33nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.