devel/p5-ExtUtils-ModuleMaker - The NetBSD Packages Collection

Perl extension for creating modules (better than h2xs)

This module is a replacement for the most typical use of the h2xs utility
bundled with all Perl distributions: the creation of the directories and
files required for a pure-Perl module to be installable with make and
distributable on the Comprehensive Perl Archive Network (CPAN).

For Perl programmers, laziness is a virtue -- and modulemaker is far and
away the laziest way to create a pure Perl distribution which meets all
the requirements for worldwide distribution via CPAN.

Build dependencies

devel/p5-IO-Capture devel/p5-Module-Build devel/p5-Capture-Tiny pkgtools/cwrappers

Runtime dependencies

devel/p5-File-HomeDir sysutils/p5-File-Copy-Recursive-Reduced lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0earmv7hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0earmv7hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0i386p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0i386p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0i386p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0powerpcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0powerpcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0powerpcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 8.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0aarch64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0aarch64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0aarch64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0alphap5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0alphap5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0alphap5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv6hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv6hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv6hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv6hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv7hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv7hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv7hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv7hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0earmv7hfp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0i386p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0i386p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0i386p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0mips64ebp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0mips64ebp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0mips64ebp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0powerpcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0powerpcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0powerpcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0sparc64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0sparc64p5-ExtUtils-ModuleMaker-0.63nb2.tgz
NetBSD 9.0sparc64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0sparc64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0sparcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0sparcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0sparcp5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz
NetBSD 9.0x86_64p5-ExtUtils-ModuleMaker-0.63nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.